axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From axelspin <spin...@knmi.nl>
Subject Re: soap address location
Date Wed, 04 Jul 2007 10:46:25 GMT

What??

 xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
 xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap12/"

I think there`s a kind of typo here? Two definition for the same namespace..
I see some exception in my console

Anyway I think you mean

xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap12/"
xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/"

and yes, it works.. but it`s quite a workaround.. sounds a bit dirty as
well..but in the mean time, I think I`ll use it


Nuno Martins wrote:
> 
> Hi all,
> 
> Problem solved. I just changed, in my wsdl, in /wsdl:definitions
> /parameter
> 
>     xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
>     xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap12/"
> 
> Regards
> 
> 
> 
> 
> Nuno Martins wrote:
>> Hi Deepal,
>>
>> It worked. My WSDL is the original except the URL in address location.
>>
>> My WSDL contains
>>
>>     <wsdl:service name="test01">
>>         <wsdl:port binding="tns:test01SoapBinding" 
>> name="test01ServerHttpPortType">
>>             <soap:address location="*https://test01.example.com?wsdl*" />
>>         </wsdl:port>
>>     </wsdl:service>
>>
>> and in my browser, my wsdl appears like this
>>
>> <wsdl:service name="test01">
>>     <wsdl:port name="test01HttpPortType" binding="tns:test01SoapBinding">
>> <soap:address 
>> location="*http://192.168.129.145:8080/test/services/signature*"/>
>> </wsdl:port>
>> </wsdl:service>
>>
>> Any ideia why URL is changed?
>>
>> Regards
>>
>>
>>
>>
>> Deepal Jayasinghe wrote:
>>> Hi Nuno ;
>>>
>>> add the following parameter into your services.xml;
>>> <parameter name="useOriginalwsdl">true</parameter>
>>>
>>> Thanks
>>> Deepal
>>>
>>>   
>>>> Hi,
>>>>
>>>> The problem is that https was changed to http and  I forgot to tell 
>>>> another thing
>>>>
>>>> https://www.test.com/axis2/services/Test1?wsdl
>>>>
>>>> was  changed to
>>>>
>>>> http://www.test.com*:8080*/axis2/services/Test1
>>>>
>>>> How can I force that wsdl in run time is the same that I created?
>>>>
>>>> Regards
>>>>
>>>>
>>>>
>>>>
>>>> Thilina Gunarathne wrote:
>>>>
>>>>     
>>>>> If the following is what you are getting, then I feel like it's
>>>>> correct..
>>>>> http://www.test.com/axis2/services/Test1
>>>>>
>>>>> What's your desired address location and what you are getting now...
>>>>>
>>>>> Thanks,
>>>>> Thilina
>>>>>
>>>>> On 12/27/06, Nuno Martins <nuno.martins@multicert.com> wrote:
>>>>>
>>>>>       
>>>>>>  Hi,
>>>>>>
>>>>>> I have deployed some sample secure service in Axis2 in Tomcat.
>>>>>>
>>>>>> When I try to generate WSDL for the service, I find that the soap
>>>>>> address
>>>>>> location is incorrect.
>>>>>>
>>>>>> The query URL is
>>>>>> https://www.test.com/axis2/services/Test1?wsdl
>>>>>> The soap address location is
>>>>>> http://www.test.com/axis2/services/Test1
>>>>>>
>>>>>> How can I change soap address location? Why is changed?
>>>>>>
>>>>>>
>>>>>> Regards
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>         
>>>>>  
>>>>>       
>>>>     
>>>  
>>>   
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/soap-address-location-tf2883512.html#a11428745
Sent from the Axis - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message