axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stlecho <stle...@gmail.com>
Subject Re: [Axis2 1.1.1] Unable to generate WSDL for this service
Date Mon, 02 Jul 2007 12:10:47 GMT

All,

Is there a solution or workaround for this issue ?

Regards, Stefan Lecho. 


stlecho wrote:
> 
> Some precisions:
> 
> The generated MessageReceiver inherits from
> org.apache.axis2.receivers.AbstractInOutSyncMessageReceiver.
> 
> Regards, Stefan Lecho.
> 
> 
> stlecho wrote:
>> 
>> Switching to Axis2 1.2 is not really an option. 
>> 
>> Adding the RPCMessageReceiver to the list of MessageReceivers solves the
>> problem, but there is a conflict with another MessageReceiver that has
>> the same "http://www.w3.org/2004/08/wsdl/in-out" mep as the
>> RPCMessageReceiver. This MessageReceiver is automatically generated by
>> the WSDL2Java tool.
>> 
>> So, how can I display the WSDL linked with a Service when using the
>> generated MessageReveiver instead of the RPCMessageReceiver ?
>> 
>> Regards, Stefan Lecho.
>> 
>> 
>> Davanum Srinivas wrote:
>>> 
>>> Please switch to Axis2 1.2 and let us know if you still see this
>>> problem.
>>> 
>>> thanks,
>>> dims
>>> 
>>> On 5/29/07, Stefan Lecho <stlecho@yahoo.com> wrote:
>>>>
>>>> All,
>>>>
>>>> I would like to display the WSDL of a WebService generated with Axis2
>>>> v1.1.1
>>>> and deployed in Tomcat v5.5.17. When using
>>>> "http://localhost:9091/itpartners-axis2-0.0.1/services/ASFInterface?wsdl",
>>>> the following error message is generated: "Unable to generate WSDL for
>>>> this
>>>> service".
>>>>
>>>> After a search in the mailing list of Axis2, I've noticed that there
>>>> are
>>>> solutions to this problem:
>>>> -check that the name attribute of the service element in services.xml
>>>> is the
>>>> same as the name attribute of the wdsl:service element in the WSDL file
>>>> =>
>>>> OK
>>>> -use the "useOriginalwsdl" parameter => OK
>>>> -use RPCMessageReceiver as messageReceiver => OK
>>>>
>>>> All the above checks are OK (files are included underneath), but I
>>>> still do
>>>> not get my WSDL file displayed correctly. Can anyone help me with this
>>>> issue
>>>> ?
>>>>
>>>> The "messageReceivers" and "parameter" section from the services.xml
>>>> file:
>>>> <service name="ASFInterface" class="be.credoc.service.SpringInit">
>>>>     <messageReceivers>
>>>>
>>>>
>>>>
>>>>
>>>>     </messageReceivers>
>>>>
>>>>     <parameter name="ServiceTCCL"
>>>> locked="false">composite</parameter>
>>>>     <parameter name="load-on-startup">true</parameter>
>>>>     <parameter name="useOriginalwsdl">true</parameter>
>>>>
>>>>
>>>> The "wsdl:service" section from the WSDL file that has been deployed in
>>>> the
>>>> WEB-INF directory of the AAR file:
>>>>     <wsdl:service name="ASFInterface">
>>>>
>>>>
>>>> Regards, Stefan Lecho.
>>>>
>>>>  ________________________________
>>>> Building a website is a piece of cake.
>>>> Yahoo! Small Business gives you all the tools to get online.
>>> 
>>> 
>>> -- 
>>> Davanum Srinivas :: http://davanum.wordpress.com
>>> 
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>>> For additional commands, e-mail: axis-user-help@ws.apache.org
>>> 
>>> 
>>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/-Axis2-1.1.1--Unable-to-generate-WSDL-for-this-service-tf3832868.html#a11392820
Sent from the Axis - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message