axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: Deploying problem - what am i missing?
Date Sun, 17 Jun 2007 19:06:41 GMT
dont know if the SampleService.java file is missing altogether or 
SampleService.java not compiled ..
lets assuming you are using SampleService is a pojo (a Plain Old Java 
Object) I dont know without looking at the WSDL but we'll assume its POJO

cd %AXIS+HOME%\samples\pojo

ant -verbose
the end distribution archive is a Axis Service Archive (*.aar)
note the location of the new .aar (archived service files) as in this 
Archived file
C:\AXIS\axis2-1.1\samples\pojo\build\AddressBookService.aar

you can either use the Admin tool to upload
http://localhost:8080/axis2-/axis2-admin/login

OR
I've had good luck by copying to WEB-INF\services
copy C:\AXIS\axis2-1.1\samples\pojo\build\*.aar 
C:\Tomcat\TOMCAT~1.5\webapps\axis2-\WEB-INF\services
shutdown axis2-
startup axis2-

Viel Gluck
Martin--
This email message and any files transmitted with it contain confidential
information intended only for the person(s) to whom this email message is
addressed.  If you have received this email message in error, please notify
the sender immediately by telephone or email and destroy the original
message without making a copy.  Thank you.

----- Original Message ----- 
From: "omega-psi" <omega-psi@gmx.de>
To: <axis-user@ws.apache.org>
Sent: Sunday, June 17, 2007 1:30 PM
Subject: Deploying problem - what am i missing?


>
> Hey there!
>
> After getting myself some good literature about Axis2 and having some 
> ideas
> in mind, i started to code. I tried to implement my first services. But
> something doesnt work, and i ran pretty much out of ideas.
>
> I have axis2-1.2 saved @ C:\axis2-1.2\ so my environment varibale 
> AXIS2_HOME
> ist set to this location. I have tried to set up the SampleService, which 
> is
> introduced @the apache site. I copied the code of SampleService.java and 
> the
> services.xml, so there are no possible typos. This is my project-tree:
> http://farm2.static.flickr.com/1439/560665214_e05287894e_o.jpg
> I create the aar by jar cvf SampleService.aar ./*. The SampleService.aar 
> has
> a size of 151kb and contains all files of the directory.
>
> I use the Web Administration application to upload the generated service
> archive, but i get an error:
> Error: org.apache.axis2.deployment.DeploymentException: Processing
> Operations Modules with an error of The following error occurred during
> schema generation: java.lang.ClassNotFoundException: Class Not found :
> org.apache.axis2.axis2userguide.SampleService at
> org.apache.axis2.deployment.repository.util.ArchiveReader.processServiceGroup(ArchiveReader.java:147)
> at ... /* Much mor in between these errors. */ 38 more Caused by:
> java.lang.ClassNotFoundException: Class Not found :
> org.apache.axis2.axis2userguide.SampleService at
> org.apache.axis2.deployment.DeploymentClassLoader.findClass(DeploymentClassLoader.java:84)
> ... 46 more
> -- 
> View this message in context: 
> http://www.nabble.com/Deploying-problem---what-am-i-missing--tf3936686.html#a11165228
> Sent from the Axis - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message