axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Walker, Jeff" <Jeff.Wal...@fmr.com>
Subject RE: WSDL2Java issue and/or help
Date Tue, 26 Jun 2007 20:48:19 GMT
This line looks odd to me also:
<xsd:import namespace="urn:org <BLOCKED::urn:org>
:pesc:core:CoreMain:v1.0.0"
schemaLocation="OrgInfo/CoreMain_v1.0.0.xsd?wsdl"/>
 
Here is a definition of how import works in XML Schema:
http://www.w3.org/TR/xmlschema-0/ section 5.4. So, the ?wsdl at the end
of the schemaLocation string looks weird.
 
I did in fact download that wsdl file, and got the same error in Axis
1.3 as you did.
I do believe the web service development team is wrong at this point.
 
----------------------------------------------------------
I also think the namespace "urn:org:pesc:core:Coremain:v1.0.0" is badly
formatted. They usually start with "http://", but I did read somewhere
they can be any unique string. Perhaps on this point, they are right.
-jeff
 


  _____  

	From: Keith Veleba [mailto:keith@intellitekservices.com] 
	Sent: Tuesday, June 26, 2007 4:03 PM
	To: axis-user@ws.apache.org
	Subject: WSDL2Java issue and/or help
	
	
	I'm writing a client for a web service and I am having an issue
with stub generation. 

	This wsdl is causing the generation to fail:
	
	
	https://uat-atc.regents.ohio.gov/ccx/OrgInfo?wsdl
	
	
	Specifically, I get an error saying it cannot find the
schemaLocation of the imported schema on line 4:
	
	
	<xsd:import namespace="urn:org:pesc:core:CoreMain:v1.0.0"
schemaLocation="OrgInfo/CoreMain_v1.0.0.xsd?wsdl"/>
	
	
	This schemaLocation looks very odd to me, but the folks who run
the web service say it is valid and should be working.
	
	
	Here's the error when I run wsdl2java.sh:
	
	
	
	
	Retrieving schema at 'OrgInfo/CoreMain_v1.0.0.xsd?wsdl',
relative to 'file:/Users/velebak/https:/uat-atc.regents.ohio.gov/ccx'.
	Exception in thread "main"
org.apache.axis2.wsdl.codegen.CodeGenerationException: Error parsing
WSDL
	        at
org.apache.axis2.wsdl.codegen.CodeGenerationEngine.<init>(CodeGeneration
Engine.java:114)
	        at
org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:32)
	        at
org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:21)
	Caused by: javax.wsdl.WSDLException: WSDLException (at
/wsdl:definitions/wsdl:types/xsd:schema): faultCode=OTHER_ERROR: An
error occurred trying to resolve schema referenced at
'OrgInfo/CoreMain_v1.0.0.xsd?wsdl', relative to
'file:/Users/velebak/https:/uat-atc.regents.ohio.gov/ccx'.:
java.io.FileNotFoundException: This file was not found:
file:/Users/velebak/https:/uat-atc.regents.ohio.gov/OrgInfo/CoreMain_v1.
0.0.xsd?wsdl
	        at com.ibm.wsdl.xml.WSDLReaderImpl.parseSchema(Unknown
Source)
	        at com.ibm.wsdl.xml.WSDLReaderImpl.parseSchema(Unknown
Source)
	        at com.ibm.wsdl.xml.WSDLReaderImpl.parseTypes(Unknown
Source)
	        at
com.ibm.wsdl.xml.WSDLReaderImpl.parseDefinitions(Unknown Source)
	        at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown
Source)
	        at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown
Source)
	        at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown
Source)
	        at
org.apache.axis2.wsdl.codegen.CodeGenerationEngine.readInTheWSDLFile(Cod
eGenerationEngine.java:276)
	        at
org.apache.axis2.wsdl.codegen.CodeGenerationEngine.<init>(CodeGeneration
Engine.java:97)
	        ... 2 more
	Caused by: java.io.FileNotFoundException: This file was not
found:
file:/Users/velebak/https:/uat-atc.regents.ohio.gov/OrgInfo/CoreMain_v1.
0.0.xsd?wsdl
	        at
com.ibm.wsdl.util.StringUtils.getContentAsInputStream(Unknown Source)
	        ... 11 more
	
	
	
	
	
	
	Any ideas what may be going on here?  It looks like it is
looking for an actual local file, but it is not local, it is hosted
remotely.
	
	
	Thanks in advance.

	
	--

	Keith E. Veleba
	President
	Intellitek Services Ltd.
	419-202-2676 cell
	keith@intellitekservices.com
	http://www.intellitekservices.com





Mime
View raw message