axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Jones" <Tjo...@metamatrix.com>
Subject RE: [Axis2/Rampart] NullPointerException when calling non-existing Webservice
Date Fri, 15 Jun 2007 14:51:42 GMT
FYI - I am seeing the same behavior in Axis2 1.2 and Rampart 1.2. 

Ted

-----Original Message-----
From: stlecho [mailto:stlecho@gmail.com] 
Sent: Friday, June 15, 2007 2:32 AM
To: axis-user@ws.apache.org
Subject: [Axis2/Rampart] NullPointerException when calling non-existing
Webservice


Hi,

We have deployed our Webservices with Axis2 v1.1.1 and Rampart v1.1.1.
When calling a non-existing Webservice, the client receives a
NullPointerException :o(. 

Tracing down the problem I've found that the cause of this problem is
the getServicePolicyKey method in the RampartMessageData class:
"msgCtx.getAxisService()" returns null.

Is there a patch available that solves - i.e. generates a user friendly
error message - this issue ?

Regards, Stefan Lecho.
--
View this message in context:
http://www.nabble.com/-Axis2-Rampart--NullPointerException-when-calling-
non-existing-Webservice-tf3926271.html#a11134524
Sent from the Axis - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message