axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: [Axis2] org.apache.axis2.AxisFault: First Element must contain the local name, Envelope
Date Sat, 23 Jun 2007 01:51:13 GMT
Looks similar to this one - http://issues.apache.org/jira/browse/AXIS2-2352

Can you please zip up your sample and upload it too?

thanks,
dims

On 6/22/07, Raghu Upadhyayula <rupadhyayula@responsys.com> wrote:
>
>
>
>
> Hi,
>
>
>
>             When I deploy my webservices on my localhost (desktop) and test
> it using a java client, it is working fine.
>
>
>
>             But when the same webservices project is built & deployed on our
> development server and tested using java client, I'm getting the below
> exception.
>
>
>
> org.apache.axis2.AxisFault: First Element must contain the local name,
> Envelope
>
> First Element must contain the local name, Envelope
>
> org.apache.axis2.AxisFault: First Element must contain the local name,
> Envelope
>
>         at
> org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:81)
>
>         at
> org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:356)
>
>         at
> org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:294)
>
>         at
> com.rsys.ws.client.ResponsysWSServiceStub.login(ResponsysWSServiceStub.java:276)
>
>         at
> com.rsys.ws.samples.TestRILoginCmd.execute(TestRILoginCmd.java:29)
>
>         at
> com.rsys.ws.samples.TestRILoginCmd.execute(TestRILoginCmd.java:16)
>
>         at
> com.rsys.ws.samples.TestResponsysWSClient.main(TestResponsysWSClient.java:40)
>
> Caused by: org.apache.axiom.soap.SOAPProcessingException:
> First Element must contain the local name, Envelope
>
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.constructNode(StAXSOAPModelBuilder.java:221)
>
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.createOMElement(StAXSOAPModelBuilder.java:179)
>
>         at
> org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:135)
>
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.getSOAPEnvelope(StAXSOAPModelBuilder.java:163)
>
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:111)
>
>         at
> org.apache.axis2.builder.BuilderUtil.getSOAPBuilder(BuilderUtil.java:474)
>
>         at
> org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:142)
>
>         at
> org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:77)
>
>         ... 6 more
>
>
>
>             Does anyone tell me why this is happening?
>
>
>
>             I'm using Axis2 deployed in Jboss.
>
>
>
> Thanks
>
> Raghu
>
>


-- 
Davanum Srinivas :: http://davanum.wordpress.com

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message