axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: ADB: getAttributeValue("",...) with JDK 1.6 stax
Date Tue, 19 Jun 2007 13:40:26 GMT
Andreas,

Please log a bug in JIRA and upload your test(s) we need to make sure
our generated code works with both parsers.

thanks,
dims

On 6/19/07, Andreas Schörk <Andreas.Schoerk@ptv.de> wrote:
>
>
>
>
> Hello,
>
> In the adb-binding-generated code of parse(…) Attributevalues are often
> requested with empty-string-namespace.
>
> I presume that in this case the namespace should not be testet.
>
>
>
> According to
> http://java.sun.com/webservices/docs/1.5/api/javax/xml/stream/XMLStreamReader.html
>
> The namespace should be null, if it is not to be checked.
>
>
>
>
>
> Looking into adbbeantemplate.xsl there is never a case where null is given
> for the namespacename, so I presumed that this is bug.
>
>
>
> Now I am a bit confused since explicitly including wstx-asl-3.2.1.jar solves
> the problem.
>
>
>
> There was a discrepancy in the definition of XMLStreamReader of 1.5,
> namespace should be null and may not be null.
>
> This has been solved in 1.6 now namespace may be null.
>
> Therefore I think in the future, in case of not wanting to check the
> namespace, null should be used as parameter as far as I know
>
> Woodstox handled this also right.
>
>
>
> Regards
>
> Andreas
>
>


-- 
Davanum Srinivas :: http://davanum.wordpress.com

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message