axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Swavek Skret" <swa...@appliedbroadband.com>
Subject RE: Classpath Problem with Weblogic 8.1 JMS Server
Date Wed, 27 Jun 2007 16:32:36 GMT
Hello Martin,

 

Thanks for the tip: Once I added the rt.jar from the BEA installation to the
classpath and used the thin BEA JMS client (wlclient.jar and
wljmsclient.jar) it started working! Thanks a lot.

 

Since my application uses a number of third party jars, I want to separate
the application jars from axis2/WEB-INF/lib directory where I have them so
far. I tried to put them into my aar file lib directory but now none of my
third party classes can be found. Here is how my aar file looks like:

 

|Archive file

|   -com

|      |-.

|   -lib

|      |-libx.jar

|      |-liby.jar

|      |-.

|   -META-INF

|      |-MANIFEST.MF

|      |-services.xml

|      |-x.wsdl

|      |-y.xsd

|      |-.

 

and I create it by copying my third party jars into the build/classes/lib/
and run 'ant jar.server'. Please let me know if I am missing any step or if
I need to do something alternative.

 

Thanks,

 

Swavek

 

From: Martin Gainty [mailto:mgainty@hotmail.com] 
Sent: Tuesday, June 26, 2007 8:03 PM
To: axis-user@ws.apache.org
Subject: Re: Classpath Problem with Weblogic 8.1 JMS Server

 

Good Evening Swavek-


com/sun/corba/se/connection/ORBSocketFactory is in

%BEA_HOME%/jdk150_06/jre/lib/rt.jar

 

HTH

Martin

This email message and any files transmitted with it contain confidential
information intended only for the person(s) to whom this email message is
addressed.  If you have received this email message in error, please notify
the sender immediately by telephone or email and destroy the original
message without making a copy.  Thank you.

----- Original Message ----- 

From: Swavek Skret <mailto:swavek@appliedbroadband.com>  

To: axis-user@ws.apache.org 

Sent: Tuesday, June 26, 2007 8:04 PM

Subject: RE: Classpath Problem with Weblogic 8.1 JMS Server

 

Hello Chad,

 

I am actually deploying on Tomcat and my application is attempting to
connect to the JMS server (Weblogic 8.1 SP5). 

 

Here is what I tried:

 

I added the weblogic.jar and wlclient.jar to axis2/WEB-INF/lib directory and
got the following error at the tomcat startup: 

Jun 26, 2007 5:49:21 PM org.apache.catalina.loader.WebappClassLoader
validateJarFile

INFO: validateJarFile(C:\Tomcat6.0\webapps\axis2\WEB-INF\lib\weblogic.jar) -
jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class:
javax/servlet/Servlet.class

 

And if the weblogic.jar is not present on the classpath, I get the following
error: [ERROR] AxisServlet - java.lang.NoClassDefFoundError:
com/sun/corba/se/connection/ORBSocketFactory.

 

These errors lead me to believe that an attempt to load weblogic.jar before
axis2 jars causes the runtime  java.land.LinkageError that  I reported
originally and an attempt to load weblogic.jar after axis2 jars fails due to
the servlet 2.3 specs issue above. Is there any alternative way to control
the application classpath?

 

Thanks,

 

Swavek

 

 

From: Chad DeBauch [mailto:cdebauch@gmail.com] 
Sent: Tuesday, June 26, 2007 7:23 AM
To: axis-user@ws.apache.org
Subject: Re: Classpath Problem

 

I am not familiar with Weblogic.  From reading the discussions I believe
there have been some issues in the past with Axis2 and Weblogic.  Perhaps
there is someone else in the group that has had this issue and can respond. 

Sorry,

Chad

On 6/26/07, Swavek Skret <swavek@appliedbroadband.com> wrote:

Hello Chad,

 

It appears that an attempt to establish a JMS connection with Weblogic 8.1
is the source of the problem. The interfaces returned by the
javax.naming.InitialContext do not seem to match javax.jms.* interfaces
(QueueConnectionFactory, QueueConnection, etc.) in the Weblogic 8.1
implementation. There are two files in axis2 libs,
geronimo-spec-jms-1.1-rc4.jar and axis2-kernel-1.2.jar, that deal with JMS
and I presume that the version of the JMS that they are using differs from
Weblogic 8.1. Could you suggest an approach to ensure that during the run
time all of the JMS will be resolved correctly (putting Weblogic jars into
the aar file won't fix it since geronimo-spec-jms-1.1-rc4.jar and
axis2-kernel-1.2.jar will be loaded first and loading Weblogic jars before
these two will cause the problem I mentioned already). Please advice.

 

Thanks,

 

Swavek

 

 

From: Chad DeBauch [mailto:cdebauch@gmail.com] 
Sent: Monday, June 25, 2007 7:42 PM
To: axis-user@ws.apache.org
Subject: Re: Classpath Problem

 

You should keep the third party jars with the aar file and tackle the
problem from that angle.  The jars in the WEB-INF/lib directory will be
loaded first so you may have conflicts with the jars that you have in your
aar or in the jars that Tomcat loads.  That is why you may be getting the
class not found exception. 

Chad

On 6/25/07, Swavek Skret <swavek@appliedbroadband.com> wrote:

When deploying the axis2.war I get the following error in the Tomcat log:

2007-06-25 12:19:36,018 ERROR org.apache.axis2.transport.http.AxisServlet -
java.lang.LinkageError: loader constraint violation: loader (instance of 
org/apache/axis2/deployment/DeploymentClassLoader) previously initiated
loading for a different type with name "javax/jms/QueueConnection"

It is possibly related to the classpath changes I did in my Tomcat settings.

When creating the aar file, I added the lib directory that included my 3rd
party jar. However, I got a class not found exceptions so I changed Tomcat
shared.loader classpath and added my 3rd party jars to it but now  I am 
getting the above error.

Does anyone have any idea of how to fix it?

Thanks,

Swavek




---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org

 

 


Mime
View raw message