axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brecht Yperman" <Brecht.Yper...@invenso.com>
Subject [Axis2] Rampart / WSS4J / WS-Security 1.1
Date Fri, 04 May 2007 13:56:04 GMT
Hi,

 

Does anyone know when, or if, WS-Security 1.1 will be supported by
WSS4J?

 

I'm trying to connect to a .NET-webservices and I'm having some
problems:

-          WSE2.0: Addressing-version in WSE2.0 is too old for
Addressing module in Axis2 1.1

-          WSE3.0: WSE3.0 uses WSS1.1, not supported by WSS4J 1.5 (or
the latest version from CVS, for that matter)

 

In other words: it is impossible, without patching Axis2-components, to
access .NET-webservices using WS-Security, which is a pity, as
Webservices are meant to be there for interoperability...

 

I am willing to spend some time on WSS4J and supporting WSS1.1, but I
don't know if I will be able to do that.

 

Thanks,

Brecht


Mime
View raw message