axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fabrice Airault <faira...@centile.com>
Subject [axis2] client side : how to get servicegroupid.
Date Thu, 24 May 2007 07:44:03 GMT
Hi,


I create a "Web Service"(axis2-1.1.1) and i want to use SoapSession but 
I never receive a servicegroupid.


i create a Stub (WebServiceWCPStub) with $AXIS2_HOME/bin/wsdl2java.sh
and my client is:
try{

WebServiceWCPStub stub = new 
WebServiceWCPStub("http://localhost:8080/axis2/services/WebServiceWCP?wsdl"); 


stub._getServiceClient().getOptions().setManageSession(true);

stub.test();
stub.test();
stub.test();
  } catch(Exception e){
e.printStackTrace();
  System.out.println("\n\n\n");
}
}


in my Service in axis2 running under tomcat.5.5.23 i have in my 
services.xml in first line  <service name="WebServiceWCP" 
scope="SOAPSession">


in my log file : logs/catalina.out
the first message send to server is :
<?xml version='1.0' encoding='utf-8'?><soapenv:Envelope 
xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope"><soapenv:Header 
/><soapenv:Body><test /></soapenv:Body></soapenv:Envelope>

the first message send to client is :
<?xml version='1.0' encoding='utf-8'?><soapenv:Envelope 
xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope"><soapenv:Header 
/><soapenv:Body><ns:testResponse 
xmlns:ns="http://wcp.ws.centile.com/xsd"><ns:return>true</ns:return></ns:testResponse></soapenv:Body></soapenv:Envelope>



why i don't receive a servicegroupid ?

Thanks

Fabrice

Mime
View raw message