axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: Loading a resource from the classpath in Axis2 with Spring
Date Fri, 09 Mar 2007 17:27:16 GMT
Ian,

So if we enforce the ServiceTCCL/composite for startUp would that fix
it? Please log a JIRA  enhancement issue.

thanks,
dims

On 3/9/07, Ian Shafer <ian@1321.org> wrote:
> Hello,
>
> I'm running Axis2 1.1.1 with Spring. I've got my ServiceTCCL set to
> composite (It'd be great to see some documentation on this; I know there
> are three settings, but I'm not exactly sure what each of them does). My
> problem is that I'm using iBATIS, which tries to load resources from the
> classpath. This doesn't work because it is not possible to set the
> ClassLoader that iBATIS uses (I think). (In my ServiceLifeCycle.startUp,
> I set Spring's ClassLoader like this:
> )appCtx.setClassLoader(service.getClassLoader()).
>
> So my question is, is there a solution for this? Right now, the only
> thing I can think of is to put the resources in the servlet's
> WEB-INF/classes directory.
>
> Also, as a side note, I am able to load the first iBATIS config file
> (because this is set in my Spring app context XML file), it's the files
> that this first config file references that cannot be read (this happens
> in iBATIS code). I tried to put all my config data in that first file,
> but iBATIS will not let you do this.
>
> Thanks for any help,
>
> Ian
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Davanum Srinivas :: http://wso2.org/ :: Oxygen for Web Services Developers

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message