axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thilina Gunarathne" <cset...@gmail.com>
Subject Re: [Axis] attachment is not transported correctly
Date Thu, 15 Feb 2007 09:59:18 GMT
I'm not sure of the Axis 1/x behaviour...

But with Axis2 I recommend you to use the DataHandler of the incoming
message to send it to the consumer rather than trying to access the
file...

Thanks,
Thilina

On 2/14/07, Manuel Ernstberger <MErnstberger@gmx.de> wrote:
> Hello,
>
> when I send a soap message with a big attachment from one web service to an other web
service and then try to access that file in order to send it to a web service consumer, then
the file is not available (input stream is null). But when I debug, the file is available.
So I guess that Axis needs some time to write the temporary file completely before it can
be accessed. Have you also had such a problem and how can you resolve it? Does that work better
with Axis2?
>
> Thanks in advance.
>
> Regards,
> Manuel
>
> P.S. Sorry for my last e-mail. I have sent it unintentionally.
> --
> "Feel free" - 10 GB Mailbox, 100 FreeSMS/Monat ...
> Jetzt GMX TopMail testen: www.gmx.net/de/go/mailfooter/topmail-out
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Thilina Gunarathne
WSO2, Inc.; http://www.wso2.com/
Home page: http://webservices.apache.org/~thilina/
Blog: http://thilinag.blogspot.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message