axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thilina Gunarathne" <cset...@gmail.com>
Subject Re: Eclipse Plugin Requirement
Date Sat, 10 Feb 2007 16:28:54 GMT
Which version of the eclipse plugin are you using...

This makes me scary with the feeling that we have not set the
compile.targets for the eclipse plugins to jdk1.4. :(...

Please log a Jira... May be we can do a new jdk1.4 compatible release
of the pluging in the 1.1.1 branch..

Thanks,
~Thilina

On 2/10/07, Chen Zhang <czhang@linkshare.com> wrote:
> I downloaded eclipse plugins for both code generation and archive
> generator wizard. After unzipping and placing them into the plugin
> folder, I restarted eclipse.When I tried to use the wizards, I got the
> error that "Plug-in ... was unable to load class
> org.apache...CodeGenWizard/ServiceArchiveWizard".
>
> I checked .log in ecplise workspace, and got the following messege. Does
> that mean they requires java 5? It is claimed in the document that java
> 1.4 should be good. I am using eclipse 3.1 with SunJDK1.4.2.
>
> !MESSAGE An error occurred while automatically activating bundle
> Axis2_Codegen_Wizard (201).
> !STACK 0
> org.osgi.framework.BundleException: The activator
> org.apache.axis2.tool.codegen.eclipse.plugin.CodegenWizardPlugin for
> bundle Axis2_Codegen_Wizard is invalid
>    at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:149)
>
>    at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:965)
>
>    at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:313)
>
>    at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:264)
>
> ...
> Caused by: java.lang.UnsupportedClassVersionError:
> org/apache/axis2/tool/codegen/eclipse/plugin/CodegenWizardPlugin
> (Unsupported major.minor version 49.0)
>    at java.lang.ClassLoader.defineClass0(Native Method)
>    at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
>    at
> org.eclipse.osgi.framework.adaptor.core.DefaultClassLoader.defineClass(DefaultClassLoader.java:370)
>
>    at
> org.eclipse.core.runtime.adaptor.EclipseClassLoader.defineClass(EclipseClassLoader.java:233)
>
>    at
> org.eclipse.osgi.framework.adaptor.core.DefaultClassLoader.findClassImpl(DefaultClassLoader.java:343)
>
> ...
> Root exception:
> java.lang.UnsupportedClassVersionError:
> org/apache/axis2/tool/codegen/eclipse/plugin/CodegenWizardPlugin
> (Unsupported major.minor version 49.0)
>    at java.lang.ClassLoader.defineClass0(Native Method)
>    at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
>    at
> org.eclipse.osgi.framework.adaptor.core.DefaultClassLoader.defineClass(DefaultClassLoader.java:370)
>
>
> Thanks.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Thilina Gunarathne
WSO2, Inc.; http://www.wso2.com/
Home page: http://webservices.apache.org/~thilina/
Blog: http://thilinag.blogspot.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message