axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anne Thomas Manes" <atma...@gmail.com>
Subject Re: AXIS1.4 can not parse the version.wsdl generated by AXIS2-1.1
Date Wed, 07 Feb 2007 02:56:53 GMT
There's an error in the WSDL.
The name attribute in the <wsdl:fault> (name="getVersionFault") must
match the name attribute in the <wsdl:part> definition that defines
the fault message (name="part1").

I suggest you switch to Axis2 1.1.1.

Anne

On 2/5/07, donald yang <donaldyy@googlemail.com> wrote:
> Hi,
>
> When I use AXIS1.4 to parse the version.wsdl generated by AXIS2-1.1, I got
> the following error:
>
> "ERROR: Missing <soap:fault> element inFault "getVersionFault" in operation
> "getVersionFault", in binding getVersion"
>
> The reason is that it has defined http binding and soap 1.2 binding.
>
> Is there anyone know how to fix this bug? many thanks inadvance.
>
> best regards
> donald
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message