axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kay* <kay2...@gmail.com>
Subject Re: setParam0(OMElement param) or xs:any
Date Tue, 27 Feb 2007 12:54:37 GMT
Thank you for your answer, but I don't understand .... can you please do an
example?Do you mean that I have to change parameters ?
Thank you very very much!!!

Kay*

2007/2/27, Deepal Jayasinghe <deepal@opensource.lk>:
>
> Hi ;
>
> When you have a method which take Object then there is no way to find
> out the type of that object. That is why it generates WSDL with xsd:any.
> To solve that U need to write the method to take the method with correct
> Object type (String [] or what ever).
>
> Thanks
> Deepal
>
> Kay* wrote:
>
> > Hello! (Sorry for my bad English...)
> > My problem is that my service is like this:
> >
> >
> > public Object[] compute(Object[]  data){
> >      //...
> > }
> >
> > and MyServiceStub.Compute has setParam0(org.apache.axiom.om.OMElement
> > [] param) and get_return returns an OMElement[]...
> > I don't know how to create an OMElement within Object[] ...and
> viceversa.
> >
> > Please, can you help me ?
> >
> > Thank you very much!!!
> >
> > Kay*
>
>
> --
> Thanks,
> Deepal
> ................................................................
> "The highest tower is built one brick at a time"
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>

Mime
View raw message