axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "donald yang" <donal...@googlemail.com>
Subject Re: How to determine the datatybe of binaray data variable
Date Wed, 14 Feb 2007 14:07:46 GMT
Hi Thilina

       Many thanks for your information.
       May I know whehter the next realease of AXIS2 will include the
features: mapping mtom attachment to xml base64binary and SwA can support
byte[]?

donald

On 2/14/07, Thilina Gunarathne <csethil@gmail.com> wrote:
>
> You will not be able to work with byte[] types seamlessly using SwA..
> Byte[] types can be only handled through MTOM or by inlining the
> binary data using a base64 encoding.
>
> MTOM provides binary support at the infoset level virtually mapping
> the attachment payloads to the XML. It's like embedding an image in a
> HTML page.  SwA attachments acts more or less as outside entities to
> the XML payloads.. They are just like sending attachments with emails.
> So it's not possible to map SwA attachments to base64 binary data
> types defined in the WSDL..
>
> AFAIK there are methods to expose SwA type of attachments in the WSDL.
> But Axis2 does not support them. They are also not straight forward as
> mapping a MTOM attachment to base64binary..
>
> ~Thilina
>
> On 2/13/07, donald yang <donaldyy@googlemail.com> wrote:
> > Hi, it seems AXIS2-1.1.1 engine only map java byte[] to xml Base64Binary
> > data type if it generates the WSDL from java code. This make third-party
> web
> > service user easily understand each input parameter. He will know that
> > parameter is a binary data.
> >
> > If I send the binary data using SwA in client side, I can not correclty
> > interpret the value for that byte array variable. I tried all
> possibilities,
> > different character set with/without decoding it using Base64. But if I
> send
> > the binary data using MTOM, I can easily interpret the value for that
> byte
> > array variable. This make my web service difficult to interoperate with
> > client using SwA. Is there anyone know how to solve this issue? Many
> thanks
> > in advance.
> >
> > best regards
> > donald
> >
> > On 2/13/07, donald yang <donaldyy@googlemail.com> wrote:
> > > Hi,
> > >
> > >
> > >
> >
> >
>
>
> --
> Thilina Gunarathne
> WSO2, Inc.; http://www.wso2.com/
> Home page: http://webservices.apache.org/~thilina/
> Blog: http://thilinag.blogspot.com/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>

Mime
View raw message