axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: [Axis2] Transport out has not been set.
Date Tue, 20 Feb 2007 12:57:35 GMT
Are u sure all the jars that come with the axis2 dist are in your
classpath? especially the commons*.jar

thanks,
dims

On 2/20/07, maskkkk <leeand00@hotmail.com> wrote:
>
> I do not have an axis2.xml file.  I am invoking the tests in 2 ways and both
> give me the error.  The first way is using the mvn test goal.  And the
> second way is to run it as a JUnit Test in Eclipse 3.1 using the JUnit
> plugin.  The files I am using are zipped up out at
> https://issues.apache.org/jira/browse/AXIS2-2222
>
> I have been following the Chad Davis thread you mentioned, although it
> doesn't seem to ever come to a conclusion.
>
> Chad seems to indicate that the code got further after he added axis2.xml.
> (I guess...)
>
> Would it be possible to post the files you have working for me?  and I could
> see if I could get them to work as you stated?
>
> Thank you,
>      Andrew J. Leer
>
>
> Tony Ambrozie wrote:
> >
> > Andrew, I was able to run your code past the issue you are reporting,
> > therefore you either have a configuration or a dependency issue.  Have you
> > modified or removed axis2.xml?  How are you invoking the tests (see
> > documentation on how Axis2 finds axis2.xml)?
> >
> > There was another report of this error that suggested a missing dependency
> > that gets somehow obscured, pls see here:
> > http://www.mail-archive.com/axis-user@ws.apache.org/msg23511.html
> >
> > Incidentally, the code eventually does throw a fault, but that seems to be
> > SOAPAction related, issue for another time.  BTW, do you really need the
> > "?WSDL" in your endpoint?
> >
> > Thanks'
> >
> >
> > On 2/19/07, maskkkk <leeand00@hotmail.com> wrote:
> >>
> >>
> >> I tried removing the setUseSeparateListener(false);
> >>
> >> That didn't really make a difference...*shrugs*
> >>
> >> I get the same error.
> >>
> >> Thank you,
> >>    Andrew J. Leer
> >>
> >>
> >> Michele Mazzucco-2 wrote:
> >> >
> >> >
> >> > Andrew,
> >> >
> >> > there's no need to set the transport out. What you did should be
> >> enough.
> >> > Just in case, try to remove the options.setUseSeparateListener(false)
> >> > call - it's set to false by default.
> >> >
> >> > Michele
> >> >
> >> >
> >> > On 19 Feb 2007, at 19:55, maskkkk wrote:
> >> >
> >> >>
> >> >> Now I understand that I've already set the "in" transport
> >> >> protocol.  But I
> >> >> really do not know how to set the "out" transport protocol or why I
> >> >> have to
> >> >> do it.  The client example in the Axis2 documentation
> >> >> ( http://ws.apache.org/axis2/1_1_1/quickstartguide.html) does not
> >> >> require
> >> >> this:
> >> >
> >> >
> >> > ---------------------------------------------------------------------
> >> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >> >
> >> >
> >> >
> >>
> >> --
> >> View this message in context:
> >> http://www.nabble.com/Transport-out-has-not-been-set.-tf3254864.html#a9053257
> >>
> >> Sent from the Axis - User mailing list archive at Nabble.com.
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >> For additional commands, e-mail: axis-user-help@ws.apache.org
> >>
> >>
> >
> >
>
> --
> View this message in context: http://www.nabble.com/Transport-out-has-not-been-set.-tf3254864.html#a9060817
> Sent from the Axis - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Davanum Srinivas :: http://wso2.org/ :: Oxygen for Web Services Developers

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message