axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen.Dav...@ipaustralia.gov.au
Subject Re: [Axis2] - module.xml not found on Axis2 / Weblogic 8.1
Date Thu, 11 Jan 2007 22:14:58 GMT
Deepal,
when deploying a modified axis2.war from Axis2 v1.1.1 into Weblogic 8.1 
(with StagingMode="nostage") the following error occurs.
(By modified I mean the released axis2.war with a weblogic.xml file added 
to deal with the classloader issue).

It appears to be related to direct deployment from a WAR file. Setting 
StagingMode="stage" makes the app deploy correctly (Weblogic unzips the 
WAR to a 'stage' directory).

Could this be related to issue Axis2-822?

<12/01/2007 08:16:20 AM EST> <Info> <HTTP> <BEA-101047> 
<[ServletContext(id=3085
6733,name=axis2,context-path=/axis2)] WebServiceServlet: init>
12/01/2007 08:16:20 org.apache.axis2.deployment.WarBasedAxisConfigurator 
getAxis
Configuration
SEVERE: org.apache.axis2.deployment.DeploymentException: module.xml not 
found  f
or the module : 
zip:C:/bea/user_projects/domains/localdev/applications/axis2.w
ar!/WEB-INF/modules/addressing-1.1.1.mar; nested exception is:
        org.apache.axis2.deployment.DeploymentException: module.xml not 
found  f
or the module : 
zip:C:/bea/user_projects/domains/localdev/applications/axis2.w
ar!/WEB-INF/modules/addressing-1.1.1.mar; nested exception is:
        org.apache.axis2.deployment.DeploymentException: module.xml not 
found  f
or the module : 
zip:C:/bea/user_projects/domains/localdev/applications/axis2.w
ar!/WEB-INF/modules/addressing-1.1.1.mar; nested exception is:
        org.apache.axis2.deployment.DeploymentException: module.xml not 
found  f
or the module : 
zip:C:/bea/user_projects/domains/localdev/applications/axis2.w
ar!/WEB-INF/modules/addressing-1.1.1.mar: loading repository from 
classpath
12/01/2007 08:16:22 org.apache.axis2.deployment.DeploymentEngine 
loadFromClassPa
th
INFO: Module validation failed  Trying to engage a module which is not 
available
 : addressing
<12/01/2007 08:16:22 AM EST> <Error> <HTTP> <BEA-101216> <Servlet:

"AxisServlet"
 failed to preload on startup in Web application: "axis2".
javax.servlet.ServletException: Trying to engage a module which is not 
available
 : addressing; nested exception is:
        org.apache.axis2.AxisFault: Trying to engage a module which is not 
avail
able : addressing
        at 
org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:348
)
        at 
weblogic.servlet.internal.ServletStubImpl$ServletInitAction.run(Servl
etStubImpl.java:1018)
        at 
weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate
dSubject.java:321)
        at 
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:
118)
        at 
weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
pl.java:894)
        at 
weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
Impl.java:873)
        at 
weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
mpl.java:812)
        at 
weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppS
ervletContext.java:3281)
        at 
weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebApp
ServletContext.java:3226)
        at 
weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAp
pServletContext.java:3207)
        at 
weblogic.servlet.internal.HttpServer.preloadResources(HttpServer.java
:694)
        at 
weblogic.servlet.internal.WebService.preloadResources(WebService.java
:483)
        at 
weblogic.servlet.internal.ServletInitService.resume(ServletInitServic
e.java:30)
        at 
weblogic.t3.srvr.SubsystemManager.resume(SubsystemManager.java:131)
        at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:966)
        at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:361)
        at weblogic.Server.main(Server.java:32)
>
Mime
View raw message