axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: [Axis2] - module.xml not found on Axis2 / Weblogic 8.1
Date Mon, 15 Jan 2007 00:37:10 GMT
Not a solution but a general direction suggestion 
Have you looked at setting up your own Weblogic webapp and construct your own configuration
files specifically ejb-jar.xml and weblogic-ejb-jar.xml ?

M-
--------------------------------------------------------------------------- 
This e-mail message (including attachments, if any) is intended for the use of the individual
or entity to which it is addressed and may contain information that is privileged, proprietary
, confidential and exempt from disclosure. If you are not the intended recipient, you are
notified that any dissemination, distribution or copying of this communication is strictly
prohibited.
--------------------------------------------------------------------------- 
Le présent message électronique (y compris les pièces qui y sont annexées, le cas échéant)
s'adresse au destinataire indiqué et peut contenir des renseignements de caractère privé
ou confidentiel. Si vous n'êtes pas le destinataire de ce document, nous vous signalons qu'il
est strictement interdit de le diffuser, de le distribuer ou de le reproduire.
  ----- Original Message ----- 
  From: Stephen.Davies@ipaustralia.gov.au 
  To: axis-user@ws.apache.org 
  Sent: Sunday, January 14, 2007 5:11 PM
  Subject: Re: [Axis2] - module.xml not found on Axis2 / Weblogic 8.1



  Deepal, 
  the stack trace I sent you is pretty useless and really doesn't show what is going wrong.


  To summarise, axis2.war will not deploy correctly on Weblogic 8.1 SP3 when being deployed
as a WAR file. Deploying as an exploded WAR file or by using the Weblogic staging mechanism
(which explodes the WAR file) allows deployment to succeed. Deploying directly from the WAR
file fails. 

  Due to some issues with the inheritance structure of DeploymentException, the stack trace
is being lost. Tracing through the code the failure stack trace would look like this: 

  org.apache.axis2.deployment.DeploymentEngine.populateModule (line 208) 
  org.apache.axis2.deployment.DeploymentEngine.loadRepositoryFromURL (line 185) 
  org.apache.axis2.deployment.WarBasedAxisConfigurator.getAxisConfiguration (line 208) 
  org.apache.axis2.transport.http.AxisServlet.init (line 333) 

  Ultimately there is a problem with the classloader returning null from the calls 
  classLoadere.getResourceAsStream("META-INF/module.xml"); and 
  classLoadere.getResourceAsStream("meta-inf/module.xml"); 
  in DeploymentEngine.populateModule. 

  Not sure where to take it from here, I'm not a classloader expert. 

  Regards, 
  Stephen 

  PS. The stack trace is being lost due to multiple catch/rethrows of DeploymentException.
DeploymentException extends AxisFault extends RemoteException extends IOException. Catch blocks
for IOException exist in DeploymentEngine.populateModule and DeploymentEngine.loadRepositoryFromURL.
WarBasedAxisConfiguration.getAxisConfiguration is catching Exception. 




------------------------------------------------------------------------------



  --
  This message contains privileged and confidential information only 
  for use by the intended recipient.  If you are not the intended 
  recipient of this message, you must not disseminate, copy or use 
  it in any manner.  If you have received this message in error, 
  please advise the sender by reply e-mail.  Please ensure all 
  e-mail attachments are scanned for viruses prior to opening or 
  using.




------------------------------------------------------------------------------


  ---------------------------------------------------------------------
  To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
  For additional commands, e-mail: axis-user-help@ws.apache.org
Mime
View raw message