axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruchith Fernando" <ruchith.ferna...@gmail.com>
Subject Re: Axis2 and https
Date Fri, 05 Jan 2007 13:19:52 GMT
Hi Dims,

We have working sample HTTPS clients in WSAS-1.1 [1] that uses the
Axis2-1.1 branch. Please see "configureSecurity" method of [2].

Thanks,
Ruchith

[1] http://www.wso2.org/projects/wsas/java
[2] https://www.wso2.org/repos/wso2/wsas/java/trunk/modules/samples/CommodityQuote/src/org/wso2/wsas/sample/commodityquote/client/Client.java


On 1/5/07, Davanum Srinivas <davanum@gmail.com> wrote:
> Ruchith,
>
> Did you test latest Axis2 1.1 branch and can you confirm if it works for you?
>
> thanks,
> dims
>
> On 1/5/07, Ruchith Fernando <ruchith.fernando@gmail.com> wrote:
> > Hi Gul,
> >
> > For the Axis2 client to work you will simply have to set the JSSE
> > system properties in your client. Please see #8 of [1] for a list of
> > JSSE properties.
> >
> > Exmaple:
> > If you configured Tomcat to use a self signed cert as its HTTPS cert.
> > Then you will have to set the " javax.net.ssl.trustStore" system
> > property to the path that holds the public key cert of the Tomcat's
> > certificate and set the password of the trust store as "
> > javax.net.ssl.trustStorePassword". If the trust store type is PKCS12
> > then you will have to set the "javax.net.ssl.trustStoreType" sys
> > property as well.
> >
> > HTH,
> >
> > Thanks,
> > Ruchith
> >
> > [1] http://java.sun.com/products/jsse/install.html
> >
> > On 1/3/07, Gul Onural <onural@nortel.com> wrote:
> > >
> > >
> > >
> > >
> > >
> > > I have spent some time to get https working for my web service using Axis2
> > > 1.1 release and nightly builds
> > > without any luck.
> > >
> > > I was wondering if anyone was able to do this successfully. If yes, do you
> > > mind sharing the details ?
> > >
> > > What I am looking for is Axis2 specifics of using https to get access to a
> > > web service deployed using Axis2.
> > >
> > > The project I am working on uses Tomcat to deploy the web service. Tomcat
> > > https configuration is easy
> > > enough, so I don't have any issues with getting Tomcat working using https.
> > > I have followed Tomcat documentation
> > > but I don't mind if you include what you have done in Tomcat configuration
> > > files, for completeness.
> > >
> > > Thanks,
> > >
> > > Gul
> > >
> > >
> > >
> >
> >
> > --
> > www.ruchith.org
> > www.wso2.org
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
>
>
> --
> Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service Developers)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
www.ruchith.org
www.wso2.org

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message