axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lucas Theisen <lthei...@us.ibm.com>
Subject Re: Code generation not working
Date Tue, 30 Jan 2007 17:11:11 GMT
Lahiru,

I got Axis2 installed along with the eclipse plugin.  I then tried to 
generate code using the xmlbeans databinding inside of eclipse.  It 
appears to generate code, however, the generated code is unable to find 
any of the org.apache.<anything> libraries.  Also, I noticed it created 
org.xmlsoap.schemas.soap.encoding classes which are only indirectly 
included, not at all part of the types section of my wsdl.  When I 
generate code using Sun's project glassfish, in the NetBeans IDE, from 
the exact same wsdl, it creates correct code, and only the classes that 
i created in the types section of my wsdl.  What should I do to remedy 
this situation?

Thanks,
Lucas

Lahiru Sandakith wrote:
> Hi Lucas,
> This is fixed now, please try the same download.
> Thanks
> sandakith
> 
> On 1/26/07, *Lucas Theisen* < ltheisen@us.ibm.com 
> <mailto:ltheisen@us.ibm.com>> wrote:
> 
>     Amila,
> 
>     It looks like I was using axis1 (which was what came standard with
>     WebSphere App Server Community Edition, based on geronimo).  Axis2
>     should be deployable to geronimo right?  Also, all the links to the
>     eclipse plugin give 404 File Not Found errors.  Do you know anywhere
>     else i can get the plugin?
> 
>     Thank you,
>     Lucas Theisen
> 
>     Amila Suriarachchi wrote:
>      > Are you using Axis2 or Axis1? Can you try eclipse plugin at
>      > http://ws.apache.org/axis2/tools/1_1/eclipse/wsdl2java-plugin.html
>      >
>      >
>      >
>      > On 1/25/07, *Lucas Theisen* <ltheisen@us.ibm.com
>     <mailto:ltheisen@us.ibm.com>
>      > <mailto: ltheisen@us.ibm.com <mailto:ltheisen@us.ibm.com>>>
wrote:
>      >
>      >     Hi,
>      >
>      >     I am trying to generate code from a ".wsdl" file.  I have
>     defined the
>      >     schema based on an application with an existing SOAP
>     API.  The schema
>      >     has a bunch of <complexType>'s.  It is my understanding that
>     each named
>      >     complex type should be generated as its own class, which is not
>      >     happening.  This is a section of my schema where this is not
>     working:
>      >
>      >     ...
>      >             <complexType name="Transaction">
>      >                     <sequence>
>      >                             <element name="message" minOccurs="0"
>      >     maxOccurs="unbounded" type="oc:Message" />
>      >                     </sequence>
>      >                     <attributeGroup ref="oc:statusAttributes" />
>      >                     <attribute name="clientId" use="optional"
>      >     type="xsd:string" />
>      >             </complexType>
>      >             <complexType name="Message">
>      >                     <sequence>
>      >                             <element name="content" minOccurs="0"
>      >     maxOccurs="unbounded"
>      >                                     type="oc:Content" />
>      >                             <element name="from" minOccurs="0"
>      >     type="xsd:string" />
>      >                             <element name="subject" minOccurs="0"
>      >     type="xsd:string" />
>      >                             <element name="recipients" minOccurs="0"
>      >                                     type="oc:Recipients" />
>      >                     </sequence>
>      >                     <attribute name="clientId" use="optional"
>      >     type="xsd:string" />
>      >                     <attributeGroup ref="oc:statusAttributes" />
>      >             </complexType>
>      >     ...
>      >             <element name="getMessageStatus">
>      >                     <complexType>
>      >                             <sequence>
>      >                                     <element name="client"
>      >     type="oc:Client" />
>      >                                     <element name="transaction"
>      >     minOccurs="0" maxOccurs="unbounded" type="oc:Transaction" />
>      >                                     <element name="message"
>     minOccurs="0"
>      >     maxOccurs="unbounded" type="oc:Message" />
>      >                         </sequence>
>      >                     </complexType>
>      >             </element>
>      >     ...
>      >
>      >     When I attempt to generate the code the getMessageStatus
>     function is
>      >     generated to take 3 arguments.  The first is correct (a
>     Client object
>      >     with an id attribute).  The second is named transaction but
>     is of type
>      >     Message[][] and the third is called message of type
>     Message[].  The
>      >     generator does not even create a Transaction class.  I am
>     using eclipse
>      >     and the web standard tools and WASCE plugin to generate the
>     code.
>      >
>      >     As a side not, I am able to generate valid code using project
>     glassfish
>      >     (sun's app server), and the netbeans ide, from the exact same
>     WSDL
>      >     file.
>      >
>      >     Thank you,
>      >     Lucas Theisen
>      >     ltheisen@us.ibm.com <mailto:ltheisen@us.ibm.com>
>     <mailto:ltheisen@us.ibm.com <mailto:ltheisen@us.ibm.com>>
>      >
>      >    
>     ---------------------------------------------------------------------
>      >     To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>     <mailto:axis-user-unsubscribe@ws.apache.org>
>      >     <mailto:axis-user-unsubscribe@ws.apache.org
>     <mailto:axis-user-unsubscribe@ws.apache.org>>
>      >     For additional commands, e-mail: axis-user-help@ws.apache.org
>     <mailto:axis-user-help@ws.apache.org>
>      >     <mailto:axis-user-help@ws.apache.org
>     <mailto:axis-user-help@ws.apache.org>>
>      >
>      >
>      >
>      >
>      > --
>      > Amila Suriarachchi,
>      > WSO2 Inc.
> 
>     ---------------------------------------------------------------------
>     To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>     <mailto:axis-user-unsubscribe@ws.apache.org>
>     For additional commands, e-mail: axis-user-help@ws.apache.org
>     <mailto:axis-user-help@ws.apache.org>
> 
> 
> 
> 
> -- 
> Regards
> Lahiru Sandakith

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message