axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Subash Devkota" <SDevk...@D2Hawkeye.com>
Subject [Axis2] How to deploy Axis2 in https
Date Fri, 15 Dec 2006 18:53:05 GMT
Hi all,

I have problem deploying axis2 1.0 in https.

I need to deploy my axis2 1.0 server over https application.

I used following configuration in axis2.xml in client side.

	<transportSender name="" class="org.apache.axis2.transport.http.CommonsHTTPTransportSender">

	         <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
		 <parameter name="Transfer-Encoding">chunked</parameter>
	</transportSender>


The web service works well when i use it in http.  But when axis2 server 
is deployed in https, the client can not connect to server (axis2 1.0 
where web services is deployed).

I am using self signed certificate in client side. I added the 
certificate of the client in https server's trusted certificate key 
store. But could not connect to server.

It throws nullPointerException while trying to connect web service.

I tried using CA certified key in the client side. In this case, it works.

I need to connect to axis2 1.0 server deployed over https with client 
that has self signed certificate.

Does any one knows how to configure the client for this?

Thanks in advance.
Subash 
 
 
PRIVACY NOTICE

This email and any attachments may be confidential and/or privileged. Use of the information
contained in this email by anyone other than the intended recipient is strictly prohibited.
If you have received this email in error, please notify the sender by replying to this message
and delete this email.

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message