axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "robert lazarski" <robertlazar...@gmail.com>
Subject Re: [Axis2] AxisFault: java.lang.ExceptionInInitializerError / NoClassDefFoundError
Date Wed, 29 Nov 2006 03:27:49 GMT
Classic error:

http://ws.apache.org/axis2/tools/1_1/CodegenToolReference.html

"An important detail is that an XMLBean class file is also generated by
WSDL2Java, TypeSystemHolder.class. That file is placed into build/classes by
the above ant task and will be needed to compile the generated sources. A
frequent problem is users get an error such as:

*ClassNotFoundException : Cannot load SchemaTypeSystem. Unable to load class
with name
schemaorg_apache_xmlbeans.system.s68C41DB812F52C975439BA10FE4FEE54.TypeSystemHolder.
Make sure the generated binary files are on the classpath.*

The TypeSystemHolder.class generated by WSDL2Java must be placed in your
classpath in order to avoid this error."
So one way to solve the issue is to follow the ant task in the tutorial.

HTH,
Robert

On 11/28/06, Shaoguang Cong <scong1111@yahoo.com> wrote:
>
> I've trouble with the mail server to reply to the message with Robert's
> response. Try again by removed original message.
>
> The default tomcat server log doesn't give much info about this
> exception. It only logs the exception name, without stack trace.
> With help from debug, my problem is narrowed down to the generated XMLBean
> resources class TypeSystemHolder cannot be found. The class is deployed in
> the aar file under the package sC22C...".  But the AxisEngine on the
> tomcat is looking for the
> TypeSystemHolder class in a package "s5808A....".  Why it does that?
> The generated and deployed XMLBean resources package isn't used.  Do you
> know how the AxisEngine figure out the package name?  Could this be a bug in
> axis2? I'm using tomcat 5.0.5.
>
> The real exception captured from debug:
>   detailMessage: java.lang.String = "Cannot load SchemaTypeSystem.
> Unable to load class with name
> schemaorg_apache_xmlbeans.system.s5808A....TypeSystemHolder. Make sure the
> generated binary
> files are on the classpath."
>
> Thanks.
> Shaoguang
>
>
> *robert lazarski <robertlazarski@gmail.com>* wrote:
>
> Um, could you paste the entire log(s)? Its not clear from your post which
> class is missing from your classpath.
>
> Robert
>
> ------------------------------
> Check out the all-new Yahoo! Mail beta<http://us.rd.yahoo.com/evt=43257/*http://advision.webevents.yahoo.com/mailbeta>-
Fire up a more powerful email and get things done faster.
>
>

Mime
View raw message