axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <andr...@runbox.com>
Subject Re: [Axis2] IllegalStateException: Current state not START_ELEMENT
Date Wed, 08 Nov 2006 19:10:47 GMT
As I said, there isn't a B2BMessageServiceServiceSkeleton.java, only a B2BMessageServiceServiceStub.java
(generated by wsdl2java). The error is definitely coming from the client side, as the service
is never invoked. Any other ideas?

----- Start Original Message -----
Sent: Wed, 8 Nov 2006 13:52:29 -0500
From: "Davanum Srinivas" <davanum@gmail.com>
To: axis-user@ws.apache.org
Subject: Re: [Axis2] IllegalStateException: Current state not START_ELEMENT

> Open the B2BMessageServiceServiceSkeleton.java in your editor and add
> some code in handleMessages method :)
> 
> -- dims
> 
> On 11/8/06, andrewb@runbox.com <andrewb@runbox.com> wrote:
> > Hi,
> >
> > I took your advice, and downloaded last night's nightly build (couldn't find a download
link to 1.1 RC2, but figured it would be similar). I replaced Axis2.war on the server, regenerated
the server- and client-side code, rebuilt the .aar, and redeployed.
> >
> > The exception I am getting now is:
> >
> > org.apache.axis2.AxisFault: Please implement com.geai.b2b.service.B2BMessageServiceServiceSkeleton#handleMessages
> >
> > handleMessages is the one and only method of my service. The stub class, B2BMessageServiceServiceStub,
has this method (else the client wouldn't compile). (I noticed the AxisFault refers to a class
ending in Skeleton, not Stub, also).
> >
> > What am I doing wrong?
> >
> > Thanks,
> >
> > Andrew B
> >
> > ----- Start Original Message -----
> > Sent: Wed, 8 Nov 2006 12:30:24 -0500
> > From: "Davanum Srinivas" <davanum@gmail.com>
> > To: axis-user@ws.apache.org
> > Subject: Re: [Axis2] IllegalStateException: Current state not START_ELEMENT
> >
> > > Please switch to 1.1 RC2 or a nightly build. We are in the process of
> > > release 1.1 final
> > >
> > > -- dims
> > >
> > > On 11/8/06, andrewb@runbox.com <andrewb@runbox.com> wrote:
> > > > Hi,
> > > >
> > > > I have written an Axis2 service, and an Axis2 client to call it. When
the client calls the stub, I get this exception:
> > > >
> > > > org.apache.axiom.om.OMException: java.lang.IllegalStateException: Current
state not START_ELEMENT
> > > >
> > > > The server-side code is not even called. I am using Axis2 1.0 for both.
Can anyone help me out with this problem please?
> > > >
> > > > Thanks,
> > > >
> > > > Andrew B
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > > >
> > > >
> > >
> > >
> > > --
> > > Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service Developers)
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> >
> > ----- End Original Message -----
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> 
> 
> -- 
> Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service Developers)
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
> 
> 

----- End Original Message -----

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message