axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruchith Fernando" <ruchith.ferna...@gmail.com>
Subject Re: org.apache.axis2.AxisFault: Module not found(Help Please)
Date Wed, 08 Nov 2006 04:00:43 GMT
Hi,

Please try using "C:\axis2-1.1-SNAPSHOT\repository\" as the repo
location. Also I noticed that you have changed the generated stub.
There should be another generated constructor where you can provide
the config context. Please use that without changing the stub.

Thanks,
Ruchith

On 11/8/06, sridhar vudutha <sridhar.jforum@gmail.com> wrote:
> Hello,
>     I have seen some posts on this Exception. Tried doing the same but still
> getting the exception. Any help would be greatly appreciated.
>
> This is what I have.
>
> Exception:
>
>
> org.apache.axis2.AxisFault: Module not found
>
> at
> org.apache.axis2.description.AxisService.engageModule(AxisService.java:478)
>
> at
> org.apache.axis2.client.ServiceClient.engageModule(ServiceClient.java:294)
>
> at
> com.cp.labs.EChainTestStatusServiceStub.<init>(EChainTestStatusServiceStub.java:118)
>
> at
> com.cp.labs.EChainTestStatusServiceStub.<init>(EChainTestStatusServiceStub.java:104)
>
> at MedToxLocalClientTest.main(MedToxLocalClientTest.java:24)
>
> Added rampart snapshot in the classpath .(modified the extension of the
> rampart module to "zip" in order to add it
> to the classpath in Eclipse)
> C:\axis2-1.1-SNAPSHOT\lib\rampart-1.1-SNAPSHOT.zip
>
> I have the mar file in the modules directory.
> C:\axis2-1.1-SNAPSHOT\modules\rampart-1.1-SNAPSHOT.mar
>
> Also I have it here.
> C:\axis2-1.1-SNAPSHOT\repository\modules\rampart-1.1-SNAPSHOT.mar
>
>
> code from the generated Generated Stub
>
>
> publicEChainTestStatusServiceStub(java.lang.String targetEndpoint) throws
> org.apache.axis2.AxisFault {
>
> //this(null,targetEndpoint);
>
> this(org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem("
> C:\\axis2-1.1-SNAPSHOT","C:\\axis2-1.1-SNAPSHOT\\conf\\axis2.xml"),
> targetEndpoint);
>
>
>
> _serviceClient.getOptions().setSoapVersionURI(
> SOAP11Constants.SOAP_ENVELOPE_NAMESPACE_URI );
>
> _serviceClient.engageModule( new QName( "rampart" ) );
>
> }
>
> Also tried engaging the module in "axis2.xml" under
> C:\\axis2-1.1-SNAPSHOT\\conf\\axis2.xml
>
> <module ref="rampart" />
>
> Also tried putting the module "rampart-1.1-SNAPSHOT.mar" under the modules
> directory in my project.
>
> C:\eclipse\workspace\myproject\modules\rampart-1.1-SNAPSHOT.mar
>
>
>
> Thanks,
>
> Sridhar.


-- 
www.ruchith.org

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message