axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <subir.sasiku...@wipro.com>
Subject RE: problem with https
Date Mon, 06 Nov 2006 13:10:02 GMT

Hi Abid,



Oops I really misread your query. I thought you said that you cannot
access the webservices deployed in https enabled server.



Well for your query [I hope you are not able to deploy your webservices
from a remote place], please enable the remote admin related parameter
for the adminservice in server-config.wsdd



<service name="AdminService" provider="java:MSG">

  <parameter name="allowedMethods" value="AdminService"/>

  <parameter name="enableRemoteAdmin" value="false"/> [This is default
'false' for security. Make it 'true' in your server]

  <parameter name="className" value="org.apache.axis.utils.Admin"/>

  <namespace>http://xml.apache.org/axis/wsdd/</namespace>

 </service>



I hope this helps.



Thanks

Subir



-----Original Message-----
From: Abid Hussain [mailto:abid.hussain@abid76.de]
Sent: Monday, November 06, 2006 5:46 PM
To: axis-user@ws.apache.org
Subject: Re: problem with https



Hallo again,



thanks for helping me.



> Is it a standard server, third party server (I mean the certificates
are

> standard ones)?

Actually I'm not sure, what you mean by standard respectively third

party server. It's a Tomcat 5.5 and it's using a Thawte Certificate.

> OR

> Is it a test server (where you might have generated the test server

> certificate)?

No, it's not a test server.

>

> One more thing is your server expecting client authentication also?

The server is inside a VPN. But the machine which I'm trying tor run the


deployment from is part of the VPN. Besides from this, there is no

authentication necessary.



I don't know if it's important for the subject, but here is the relevant


part from the web.xml.



<?xml version="1.0" encoding="UTF-8"?>

<web-app ...>

          <!-- .... -->

          <servlet>

                   <display-name>

                   Apache-Axis Servlet</display-name>

                   <servlet-name>AxisServlet</servlet-name>

                   <servlet-class>


org.apache.axis.transport.http.AxisServlet</servlet-class>

          </servlet>

          <servlet>

                   <display-name>

                   Axis Admin Servlet</display-name>

                   <servlet-name>AdminServlet</servlet-name>

                   <servlet-class>


org.apache.axis.transport.http.AdminServlet</servlet-class>

                   <load-on-startup>100</load-on-startup>

          </servlet>



          <!-- .... -->



          <servlet-mapping>

                   <servlet-name>AxisServlet</servlet-name>

                   <url-pattern>/servlet/AxisServlet</url-pattern>

          </servlet-mapping>

          <servlet-mapping>

                   <servlet-name>AxisServlet</servlet-name>

                   <url-pattern>*.jws</url-pattern>

          </servlet-mapping>

          <servlet-mapping>

                   <servlet-name>AxisServlet</servlet-name>

                   <url-pattern>/services/*</url-pattern>

          </servlet-mapping>

          <servlet-mapping>

                   <servlet-name>AdminServlet</servlet-name>

                   <url-pattern>/servlet/AdminServlet</url-pattern>

          </servlet-mapping>

          <!-- .... -->

</web-app>



Best regards,



Abid Hussain



>

> Regards,

> Subir S

>

> -----Original Message-----

> From: Abid Hussain [mailto:abid.hussain@abid76.de]

>

> Sent: Friday, November 03, 2006 9:52 PM

> To: axis-user@ws.apache.org

> Subject: problem with https

>

> Hi everybody,

>

> I am new to axis and have a problem deploying my Webservice. I am
using

>

> Axis 1.3 and get always an error when trying to deploy it on the
remote

>

> server. I think it is because the server is only accessible via HTTPS
-

>

> when I deploy it on my local machine everything goes fine. Axis always

>

> responds with <401 unauthorized>.

>

> Would be very happy, if someone could help me :-)

>

> My Ant Script looks like this:

> <target name="installWebservice">

>        <mkdir dir="WebContent/wsdl" />

>        <java classname="org.apache.axis.wsdl.Java2WSDL" fork="true"

>

> classpathref="axis.classpath" failonerror="true">

>                 <arg line="-o WebContent/wsdl/ModuleWS.wsdl" />

>                 <arg line="-l

> https://xxx.yyy:16384/modulverwaltung/services/ModuleWS"/>

>                 <arg line="-n urn:ModuleWS" />

>                 <arg line="modulverwaltung.service.ModuleWSImpl" />

>        </java>

>        <java classname="org.apache.axis.wsdl.WSDL2Java" fork="true"

>

> classpathref="axis.classpath">

>                 <arg line="-s WebContent/wsdl/ModuleWS.wsdl" />

>                 <arg line="-o src" />

>                 <arg line="-p modulverwaltung.service.ws" />

>        </java>

>        <!-- other operations... -->

> </target>

>

> Until here everything goes fine.

> No I install the .war File where my Webapp and all the Axis stuff is

>

> included on the server. After that, I try deploy the Webservice using

>

> following script:

> <target name="deployWebservice">

>        <java classname="org.apache.axis.client.AdminClient"
fork="true"

>

> classpathref="axis.classpath" failonerror="true">

>        <arg line="-l

> https://xxx.yyy:16384/modulverwaltung/servlet/AxisServlet

>

> WebContent/WEB-INF/ModuleWS/deploy.wsdd" />

>        </java>

> </target>

>

> But the deployment fails. The Message is:

> [java] Processing file WebContent/WEB-INF/ModuleWS/deploy.wsdd

> [java] Exception: AxisFault

> [java] faultCode: {http://xml.apache.org/axis/}HTTP

> [java] faultSubcode:

> [java] faultString: (401)Unauthorized

> [java] faultActor:

> [java] faultNode:

> [java] faultDetail:

> [java] {}:return code:  401

> [java] &lt;?xml version=&quot;1.0&quot;

>

> encoding=&quot;utf-8&quot;?&gt;&lt;soapenv:Envelope

>

> xmlns:soapenv=&quot;http://schemas.xmlsoap.

> org/soap/envelope/&quot;

>

> xmlns:xsd=&quot;http://www.w3.org/2001/XMLSchema&quot;

>

> xmlns:xsi=&quot;http://www.w3.org/2001/XMLSchema-instance&qu

> ot;&gt;&lt;soapenv:Body&gt;&lt;soapenv:Fault&gt;&lt;faultcode

>

>
xmlns:ns1=&quot;http://xml.apache.org/axis/&quot;&gt;ns1:Server.Unauthor

> ized&l

> t;/faultcode&gt;&lt;faultstring&gt;Remote administrator access is not

>

> allowed!&lt;/faultstring&gt;&lt;detail&gt;&lt;ns2:hostname xmlns:ns2=&

>
quot;http://xml.apache.org/axis/&quot;&gt;lee.mi.fu-berlin.de&lt;/ns2:ho

> stname&gt;&lt;/detail&gt;&lt;/soapenv:Fault&gt;&lt;/soapenv:Body&gt;

> &lt;/soapenv:Envelope&gt;

> [java] {http://xml.apache.org/axis/}HttpErrorCode:401

>

> Best regards,

>

> Abid

>

> --

>

>

> Abid Hussain

> Mail: abid.hussain@abid76.de

> Web: http://www.abid76.de

>

> ---------------------------------------------------------------------

> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org

> For additional commands, e-mail: axis-user-help@ws.apache.org

>

>

>

> The information contained in this electronic message and any
attachments to this message are intended for the exclusive use of the
addressee(s) and may contain proprietary, confidential or privileged
information. If you are not the intended recipient, you should not
disseminate, distribute or copy this e-mail. Please notify the sender
immediately and destroy all copies of this message and any attachments.

>

>

> WARNING: Computer viruses can be transmitted via email. The recipient
should check this email and any attachments for the presence of viruses.
The company accepts no liability for any damage caused by any virus
transmitted by this email.

>

>

> www.wipro.com

>

> ---------------------------------------------------------------------

> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org

> For additional commands, e-mail: axis-user-help@ws.apache.org

>

>



--



Abid Hussain

Mail: abid.hussain@abid76.de

Web: http://www.abid76.de



---------------------------------------------------------------------

To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org

For additional commands, e-mail: axis-user-help@ws.apache.org






The information contained in this electronic message and any attachments to this message are
intended for the exclusive use of the addressee(s) and may contain proprietary, confidential
or privileged information. If you are not the intended recipient, you should not disseminate,
distribute or copy this e-mail. Please notify the sender immediately and destroy all copies
of this message and any attachments.

WARNING: Computer viruses can be transmitted via email. The recipient should check this email
and any attachments for the presence of viruses. The company accepts no liability for any
damage caused by any virus transmitted by this email.

www.wipro.com
Mime
View raw message