axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Hachmann" <axis.pub...@thesofa.de>
Subject AW: No Object Found for java.util.Calendar
Date Tue, 07 Nov 2006 21:44:52 GMT
Hello,
I still have not found an answer to my problem. 
Does really no one have a clue where the problem could be. I know, that this
once used to work. No the Service
Alswas collapses on the cliend side for an AxisFault reason due to the
java.utils.Calendar.

<element name="starttime" nillable="true" type="xsd:datetime"/> 
Is the mapping in the mapping bean.

private Calendar starttime

And

private Date starttime

Do both not work. 
The get and set Methods do exist ;-)

Can please anyone help me with this.??

-----Urspr√ľngliche Nachricht-----
Von: Alexander Hachmann [mailto:axis.public@thesofa.de] 
Gesendet: Dienstag, 24. Oktober 2006 17:36
An: axis-user@ws.apache.org
Betreff: No Object Found for java.util.Calendar


Hello,

I have a strange problem with deserializing the XML-Data reveived from a
Webservice.
I Know that there has been a question about this yet on the 30th of august.
But I could not find any answer to that thread, so I am posting this issue
again.

My WebService returns an ComplexType being BeanMapped with Type dateTime in
it which should be parsed to java.util.Calendar.
When I run the client in debug mode in eclipse, i reveive the following
exception:

	org.xml.sax.SAXException: No object was found for class type class
java.util.Calendar

But the soapdata thats returned by the server is correct and The strangest
thing about this is, that when I run this client in non Debug mode, I won't
receive this exception.

I am using Axis 1.4.2_08-b03

Can anyone give me a hint? I need this to get work even when debuggin.

Thx,
   Alexander



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message