axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Neu" <peter....@gmx.net>
Subject AW: [Axis2] Trouble with WS routing through proxy server
Date Tue, 28 Nov 2006 12:57:32 GMT
Hello,

didn't knew I would need this. So I looked here: 

http://ws.apache.org/axis2/1_1/http-transport.html#auth

If I get this right, I use the original server and port address (not the one
of the proxy) in stub and paste this code into the stub, right? But where
does this code go? 

Options options = new Options();
HttpTransportProperties.ProxyProperties proxyProperties = new
HttpTransportProperties.new ProxyProperties();
proxyProperties.setProxyHostName(xxx.xxx.xxx.xxx);
proxyProperties.setProxyPort(80);
options.setProperty(HttpConstants.PROXY, proxyProperties); 


In the axis2.xml on the tomcat server I have to make these changes, right? 

<transportSender name=""
class="org.apache.axis2.transport.http.CommonsHTTPTransportSender">
        <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
        <parameter name="PROXY" proxy_host="proxy_host_name"
proxy_port="proxy_host_port"
locked="true>anonymous:anonymous:anonymous</parameter>
</transportSender>

This means I can't no longer connect directly to the server but have to
always go through the proxy, right?

Cheers,
Pete 





> -----Urspr√ľngliche Nachricht-----
> Von: Michele Mazzucco [mailto:Michele.Mazzucco@ncl.ac.uk]
> Gesendet: Montag, 27. November 2006 16:55
> An: axis-user@ws.apache.org
> Betreff: Re: [Axis2] Trouble with WS routing through proxy server
> 
> Hi Pete,
> 
> have you set up the proxy settings in your axis2 client
> (HttpTransportProperties.ProxyProperties)?
> 
> Michele
> 
> On 27 Nov 2006, at 10:30, Peter Neu wrote:
> 
> > Hello,
> >
> > I got some problems with a proxy server setup. The tomcat server
> > (5.5.9)
> > running axis2 sits behind a proxy server which is apache httpd 2.0.49
> > normally this works well but in case of web services the client cannot
> > connect to the axis service through
> > httpd. I get the usual java.net timeout exception :
> > java.net.SocketTimeoutException: Read timed out
> >
> > In the httpd access log I only see this line:
> >
> > 192.168.200.188 - - [27/Nov/2006:11:33:26 +0100] "POST
> > /axis2/services/binarytest HTTP/1.1" 413 1703 "-" "Axis2"
> >
> > No further hints to what might be going wrong.
> >
> > My Web Service is transmitting small documents ~300kb.
> >
> > Any ideas what could be wrong?
> >
> > Cheers,
> > Pete
> >
> >
> >
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message