axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Keiler <christian_1...@web.de>
Subject Re: ClassCastException in CryptoFactory.java (wss4j)
Date Thu, 19 Oct 2006 12:59:50 GMT
Hi again,

I've solved the problem my myself. The root problem was a wrong 
ClassLoader, which was taken, because the concerning libs were deployed 
with the Service itself (not the jars but the class files). Moving the 
libs (as jars) to the WEB-INF/lib directory, solved all problems.

I hope, that my errors can help other users, too.

Have a nice day,
Christian

Christian Keiler wrote:
> Hi,
> 
> I want to make my WebService securely running. Meanwhile I have a 
> problem on this.
> While debugging I recognized the following line in CryptoFactory.java in 
> the source of wss4j (I'm using rampart):
> crypto = (Crypto) c.newInstance(new Object[]{properties,loader});
> 
> The instance is created perfectly (on debugging I run through the 
> constructor), but I still get a ClassCastException. I tried the 
> default-Implementation of Merlin as the according Crypto implementation, 
> since my sec.properties has the line
> org.apache.ws.security.crypto.provider=org.apache.ws.security.components.crypto.Merlin

> 
> 
> Did anyone else also experience this problem? What could be a proper 
> solution?
> 
> Thanks in advance,
> Christian

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message