axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Hollerith" <a...@hollerith.net>
Subject Re: [Axis2] Soap 1.2 issue?
Date Wed, 11 Oct 2006 04:19:09 GMT
thanks for your reply,

you were able to send:
SOAPAction: "http://ncpower.norcom.de/archive/arm/webservice/requestTransport"
Content-Type: application/soap+xml; charset=utf-8;

do you think that this should also work (this is sent in one line in the http
header)?
Content-Type: application/soap+xml; charset=utf-8;
action="http://ncpower.norcom.de/archive/arm/webservice/requestTransport"

from my understanding it is conforming to the SOAP 1.2 standard, but i am not
really sure...

i am using axis2 1.0 at the moment. we will try to make a switch to 1.1 today
and see what happens - could you point me to the place in the axis2 code
where i can try to deal with this or would this be a question to the developer
list?

thanks again for your reply.
alex 

On Tue, 10 Oct 2006 23:11:57 -0400, Davanum Srinivas wrote
> Alex,
> 
> I was able to send the following request w/o any problem using latest
> nightly (from 1.1 branch)
> 
> Thanks,
> dims
> 
> POST /axis2/services/ARMService HTTP/1.1
> SOAPAction: "http://ncpower.norcom.de/archive/arm/webservice/requestTransport"
> Content-Type: application/soap+xml; charset=utf-8;
> User-Agent: Axis/2.0
> Host: 192.168.1.101:8081
> Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2
> Connection: keep-alive
> Content-Length: 800
> 
> <?xml version="1.0" encoding="utf-8"?>
> <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><requestTransportIn
> xmlns="http://ncpower.norcom.de/archive/arm/webservice">
> <supportID xmlns="">applicationName</supportID>
> <trackID xmlns="">66</trackID>
> <orderNumber xmlns="">10</orderNumber>
> <assetID xmlns="">assetID-42</assetID>
> <userID xmlns="">7</userID>
> <ipAddress xmlns="">ipAddress</ipAddress>
> <applicationName xmlns="">applicationName</applicationName>
> <sourceSystem xmlns="">ssdfgsf</sourceSystem>
> <targetSystem xmlns="">targetSystem</targetSystem>
> <ingestOptions xmlns="">ingestOptions</ingestOptions>
> </requestTransportIn>
> </soap:Body>
> </soap:Envelope>
> 
> On 10/10/06, Davanum Srinivas <davanum@gmail.com> wrote:
> > Smells like a bug, Are u using RC1? Could i pester you to open a JIRA bug?
> >
> > thanks,
> > dims
> >
> > On 10/10/06, Alex Hollerith <alex@hollerith.net> wrote:
> > > hello,
> > >
> > > we are seeing strange behaviour with an axis 2 based web-service.
> > > maybe somebody can point me into the right direction to solve this
> > > issue - i am lost and desperate... everything was perfect until we
> > > tried to connect to the service with a .net based client...
> > >
> > > wsdl of the service is attached to this mail
> > >
> > > situation is the follwoing:
> > >
> > > if i generate a request with soapUI everthing works as excpected. the flow
> > > is the following (intercepted with tcpmon):
> > >
> > > *****************************************************************
> > > Request
> > > *****************************************************************
> > >
> > > POST /axis2/services/ARMService HTTP/1.1
> > > Content-Type: text/xml;charset=UTF-8
> > > SOAPAction:
"http://ncpower.norcom.de/archive/arm/webservice/requestTransport"
> > > User-Agent: Jakarta Commons-HttpClient/3.0.1
> > > Host: 127.0.0.1:8050
> > > Content-Length: 598
> > >
> > > <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
> > > xmlns:web="http://ncpower.norcom.de/archive/arm/webservice">
> > >    <soapenv:Header/>
> > >    <soapenv:Body>
> > >       <web:requestTransportIn>
> > >          <supportID>?</supportID>
> > >          <trackID>?</trackID>
> > >          <orderNumber>10</orderNumber>
> > >          <assetID>?</assetID>
> > >          <userID>?</userID>
> > >          <ipAddress>?</ipAddress>
> > >          <applicationName>?</applicationName>
> > >          <sourceSystem>?</sourceSystem>
> > >          <targetSystem>?</targetSystem>
> > >       </web:requestTransportIn>
> > >    </soapenv:Body>
> > > </soapenv:Envelope>
> > >
> > > *****************************************************************
> > > Response
> > > *****************************************************************
> > > HTTP/1.1 200 OK
> > > Server: Apache-Coyote/1.1
> > > Set-Cookie: JSESSIONID=212D733FD619B695F878CCB7DF59ABA6; Path=/axis2
> > > Content-Type: text/xml;charset=UTF-8
> > > Transfer-Encoding: chunked
> > > Date: Tue, 10 Oct 2006 20:42:18 GMT
> > >
> > > 144
> > > <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope
> > > xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header
> > > /><soapenv:Body><ns1:requestTransportOut
> > >
xmlns:ns1="http://ncpower.norcom.de/archive/arm/webservice">5ad09517a7522b35-4e77e631e96a12cb</ns1:requestTransportOut></soapenv:Body></soapenv:Envelope>
> > > 0
> > >
> > >
> > >
> > >
> > > if i use a .net based client to generate the request the operation is not
> > > found - the flow is the following (once again intercepted with tcpmon):
> > > *****************************************************************
> > > Request
> > > *****************************************************************
> > >
> > > POST /axis2/services/ARMService HTTP/1.1
> > > User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; MS Web Services Client
Protocol
> > > 2.0.50727.42)
> > > Content-Type: application/soap+xml; charset=utf-8;
> > > action="http://ncpower.norcom.de/archive/arm/webservice/requestTransport"
> > > Host: 127.0.0.1:8050
> > > Content-Length: 773
> > > Expect: 100-continue
> > > Connection: Keep-Alive
> > >
> > > <?xml version="1.0" encoding="utf-8"?>
> > > <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"
> > > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> > > xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><requestTransportIn
> > > xmlns="http://ncpower.norcom.de/archive/arm/webservice">
> > > <supportID xmlns="">applicationName</supportID>
> > > <trackID xmlns="">66</trackID>
> > > <orderNumber xmlns="">10</orderNumber>
> > > <assetID xmlns="">assetID-42</assetID>
> > > <userID xmlns="">7</userID>
> > > <ipAddress xmlns="">ipAddress</ipAddress>
> > > <applicationName xmlns="">applicationName</applicationName>
> > > <sourceSystem xmlns="">ssdfgsf</sourceSystem>
> > > <targetSystem xmlns="">targetSystem</targetSystem>
> > > <ingestOptions xmlns="">ingestOptions</ingestOptions>
> > > </requestTransportIn>
> > > </soap:Body>
> > > </soap:Envelope>
> > >
> > > *****************************************************************
> > > Response
> > > *****************************************************************
> > > HTTP/1.1 100 Continue
> > >
> > > HTTP/1.1 500 Internal Server Error
> > > Server: Apache-Coyote/1.1
> > > Set-Cookie: JSESSIONID=F61581459BCBEDCE5F209C1936C4B47A; Path=/axis2
> > > Content-Type: application/soap+xml;charset=utf-8
> > > Transfer-Encoding: chunked
> > > Date: Tue, 10 Oct 2006 20:43:01 GMT
> > > Connection: close
> > >
> > > 219
> > > <?xml version='1.0' encoding='utf-8'?><soapenv:Envelope
> > > xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope"
> > >
xmlns:wsa="http://www.w3.org/2005/08/addressing"><soapenv:Header><wsa:ReplyTo><wsa:Address>http://www.w3.org/2005/08/addressing/anonymous</wsa:Address></wsa:ReplyTo><wsa:MessageID>urn:uuid:5B6AAF934F1F8D17D9116051298123461</wsa:MessageID><wsa:Action>http://www.w3.org/2005/08/addressing/fault</wsa:Action></soapenv:Header><soapenv:Body><soapenv:Fault><soapenv:Code><soapenv:Value>soapenv:Sender</soapenv:Value></soapenv:Code>
> > > b0
> > > <soapenv:Reason><soapenv:Text xml:lang="en-US">Operation Not found
EPR is
> > > http://127.0.0.1:8050/axis2/services/ARMService and WSA Action =
> > > null</soapenv:Text></soapenv:Reason>
> > > 762
> > > <soapenv:Detail><Exception>org.apache.axis2.AxisFault: Operation
Not
found EPR
> > > is http://127.0.0.1:8050/axis2/services/ARMService and WSA Action = 
null&#13;
> > >         at
> > >
org.apache.axis2.engine.DispatchPhase.checkPostConditions(DispatchPhase.java:46)&#13;
> > >         at org.apache.axis2.engine.Phase.invoke(Phase.java:396)&#13;
> > >         at
org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:473)&#13;
> > >         at
org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:445)&#13;
> > >         at
> > >
org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:284)&#13;
> > >         at
org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:136)&#13;
> > >         at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)&#13;
> > >         at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)&#13;
> > >         at
> > >
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)&#13;
> > >         at
> > >
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)&#13;
> > >         at
> > >
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)&#13;
> > >         at
> > >
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)&#13;
> > >         at
> > >
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)&#13;
> > >         at
> > >
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)&#13;
> > >         at
> > >
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)&#13;
> > >         at
> > >
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)&#13;
> > >         at
> > >
org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:833)&#13;
> > >         at
> > >
org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:639)&#13;
> > >         at
org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1285)&#13;
> > >         at java.lang.Thread.run(Unknown Source)&#13;
> > > </Exception></soapenv:Detail>
> > > 32
> > > </soapenv:Fault></soapenv:Body></soapenv:Envelope>
> > >
> > > this looks like a valid soap 1.2 request to me. did i oversee something?
> > >
> > > thanks for your support
> > > alex
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> > >
> >
> >
> > --
> > Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service Developers)
> >
> 
> -- 
> Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service 
> Developers)
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message