axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: Axis2 1.1 Code Generation Problem?
Date Mon, 30 Oct 2006 06:50:09 GMT
Brian,

there were problems with all 3 wsdl's. Somehow sneaked in. Fixed all 3
and added more locations where we throw informative exceptions. Please
get a nightly build in another couple of hours.

thanks,
dims

On 10/29/06, axis2@coxco.com <axis2@coxco.com> wrote:
> Here are the standard Axis2 wsdl's which have the same problem as the new
> one I am creating.
>
> Thanks for the help.
>
> Brian
>
>
> -----Original Message-----
> From: Matthew Hannay [mailto:matt_hannay1@yahoo.com.au]
> Sent: Sunday, October 29, 2006 11:18 PM
> To: axis-user@ws.apache.org
> Subject: Re: Axis2 1.1 Code Generation Problem?
>
> Can you post your WSDL?
> I can have a look at it. Are you using wsdl 1.1 or 2.0
>
> Matt
> --- "C. Brian Cox" <axis2@coxco.com> wrote:
>
> > I have been working on a WSDL, and ran into a
> > problem when trying to make
> > use of simple types.  So I tried to generate from
> > some of the sample wsdl's
> > included in the standard source distribution,
> > namely: actionTests.wsdl,
> > bookQuote.wsdl, and bookQuote2.wsdl.  Each of these
> > contain simple data
> > types similar to my wsdl.  The thought here was to
> > test a known good wsdl vs
> > my new untested wsdl.  This resulted in similar
> > exceptions.
> >
> >
> >
> > I believe I am using the code generation tools
> > correctly.  For the
> > bookQuote.wsdl I used the following command:
> >
> >
> >
> > C:\BookQuote> wsdl2java -uri BookQuote.wsdl -d
> > xmlbeans -o client -p
> > com.ems.client
> >
> >
> >
> > Using AXIS2_HOME:   "C:\axis2-1.1"
> >
> > Using JAVA_HOME:    "C:\Progra~1\Java\jdk1.5.0_06"
> >
> >
> >
> > This results in an exception similar to the ones I
> > am experiencing with my
> > own wsdl:
> >
> >
> >
> > Exception in thread "main"
> >
> org.apache.axis2.wsdl.codegen.CodeGenerationException:
> >
> org.apache.axis2.wsdl.codegen.CodeGenerationException:
> > java.lang.RuntimeException: Element QName is null
> > for InvalidIsbnFault!
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEn
> > gine.java:224)
> >
> >             at
> >
> org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:32)
> >
> >             at
> >
> org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:21)
> >
> > Caused by:
> >
> org.apache.axis2.wsdl.codegen.CodeGenerationException:
> > java.lang.RuntimeException: Element QName is null
> > for InvalidIsbnFault!
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.e
> >
> mitStub(AxisServiceBasedMultiLanguageEmitter.java:299)
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEn
> > gine.java:213)
> >
> >             ... 2 more
> >
> > Caused by: java.lang.RuntimeException: Element QName
> > is null for
> > InvalidIsbnFault!
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.g
> >
> etFaultParamElements(AxisServiceBasedMultiLanguageEmitter.java:1877)
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.g
> >
> etFaultElement(AxisServiceBasedMultiLanguageEmitter.java:1808)
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.g
> >
> enerateMethodElement(AxisServiceBasedMultiLanguageEmitter.java:1559)
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.l
> >
> oadOperations(AxisServiceBasedMultiLanguageEmitter.java:1474)
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.c
> >
> reateDOMDocumentForCallbackHandler(AxisServiceBasedMultiLanguageEmitter.java
> > :692)
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.w
> >
> riteCallBackHandlers(AxisServiceBasedMultiLanguageEmitter.java:667)
> >
> >             at
> >
> org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.e
> >
> mitStub(AxisServiceBasedMultiLanguageEmitter.java:274)
> >
> >             ... 3 more
> >
> >
> >
> >
> >
> > Should it matter, I am using Axis2 RC1, and also
> > tested it with the 10/29
> > 1.1 Snapshot.  I am using the JDK 1.4.3 but also
> > tested with 1.5.  I am
> > curious if anyone else has experienced this problem
> > and if this is a known
> > bug.  I looked at the JIRA but didn't see the exact
> > problem.
> >
> >
> >
> > Thanks,
> >
> >
> >
> > Brian
> >
> >
> >
> >
>
>
>
>
>
> Send instant messages to your online friends http://au.messenger.yahoo.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
>


-- 
Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service Developers)

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message