axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "robert lazarski" <robertlazar...@gmail.com>
Subject Re: JBoss strange problem with Axis2 WebServices deployed in a ear file
Date Fri, 08 Sep 2006 14:31:41 GMT
Are you placing the axis2 jars at the war level or the ear level ?
jboss-web.xml in the war case, jboss-app.xml in the ear case.

Hint in the ear case:

<jboss-app>
    <loader-repository>
        jboss.loader:loader=myapp.ear
        <loader-repository-config>java2ParentDelegation=true</loader-repository-config>
    </loader-repository>
</jboss-app>

HTH,
Robert

On 9/8/06, Z Chen <zc_888@yahoo.com> wrote:
> Hi,
>
> I need an urgent help here. I am deploying a ear file
> with Axis2 web services as a war file in it. In my
> manifest file, I included all the jar files such as
> stax-api.jar.
>
> But during the service invoking, Jboss server hangs at
> QName.getLocalPart() in one of the generated Receiver
> classes. And it blows up the JBoss server if I send
> another service request.
>
> I realized stax-api.jar has QName class in it and
> JBoss also has namespace.jar which has QName class.
> Did anyone experience the similar problem before or
> anyone know how to track down the problem ?
>
> Thanks !
>
> Looking forward to any type of advice.
>
> John
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message