axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anne Thomas Manes" <atma...@gmail.com>
Subject Re: [Axis2] Migrate from Axis2 0.94 to Axis2 1.0
Date Wed, 27 Sep 2006 11:17:15 GMT
I suggest you wait for Axis2 1.1, which should be released next week.

On 9/27/06, Xinjun Chen <xjchen001@gmail.com> wrote:
> More error messages:
>
> java.rmi.RemoteException: EJB Exception:; nested exception is:
>  java.rmi.RemoteException: Server was unable to process request. --> The
> underlying connection was closed: Unable to connect to the remote server.
> --> The remote server returned an error: (407) Proxy Authentication Required
> .; nested exception is:
>  com.crimsonlogic.wsg.client.DeliveryChannelException:
> Server was unable to process request. --> The underlying connection was
> closed: Unable to connect to the remote server. --> The remote server
> returned an error: (407) Proxy Authentication Required.
>  at
> weblogic.rjvm.BasicOutboundRequest.sendReceive(BasicOutboundRequest.java:108)
>  at
> weblogic.rmi.internal.BasicRemoteRef.invoke(BasicRemoteRef.java:138)
>  at
> com.wsg.core.protocol.ejb.WSGEJBAdapter_kjgyxr_EOImpl_812_WLStub.sendSync
> (Unknown Source)
>  at
> com.wsg.tnl.tx.WSCommService.ProcessMessage(WSCommService.java:79)
>  at
> wsg.sample.security.CCNWSClient.main(CCNWSClient.java:20)
> Caused by: java.rmi.RemoteException: Server was unable to process request.
> --> The underlying connection was closed: Unable to connect to the remote
> server. --> The remote server returned an error: (407) Proxy Authentication
> Required.; nested exception is:
>  com.crimsonlogic.wsg.client.DeliveryChannelException:
> Server was unable to process request. --> The underlying connection was
> closed: Unable to connect to the remote server. --> The remote server
> returned an error: (407) Proxy Authentication Required.
>  ... 10 more
>
> Thanks for any suggestions and comments.
>
>
> Regards,
> Xinjun
>
>
>
> On 9/27/06, Xinjun Chen <xjchen001@gmail.com> wrote:
> >
> > Hi,
> > I have an application which works fine with Axis2 0.94.
> > Yesterday I tried to migrate the Axis2 lib to 1.0. Then I get some error
> messages I cannot understand.
> >
> > The error message is:
> > unknown attr1.3.6.1.4.1.311.17.1
> > org.apache.ws.security.WSSecurityException: Signature
> creation failed (Cannot setup signature data structure)
> >         at
> org.apache.ws.security.message.WSSecSignature.prepare(
> WSSecSignature.java:323)
> >         at
> org.apache.ws.security.message.WSSecSignature.build(WSSecSignature.java:643)
> >         ...
> >
> > I googled "unknown attr1.3.6.1.4.1.311.17.1" and find it is something
> related to interoperability issues on PKCS12 between Microsoft and Sun JDK.
> But my question is that previously when I use Axis2 0.94 it is ok.
> >
> > Can you shed some lights on this?
> >
> >
> > Regards,
> > Xinjun
> >
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message