axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Sprick" <felix.spr...@netlight.se>
Subject SV: problem when running wsdl2java with axis2
Date Tue, 19 Sep 2006 14:55:44 GMT
Hi Martin,

 

Thanks a lot for your answer. I am not sure where to locate
“local/Schemas/Byggnader.xsd”, is that kind of a temp directory? I can,
however, attach the original Byggnader.xsd file, if that is of any help for
you. Since I am not sure whether this mailing list allows attachments, I
have put all my xsds in a zip file at http://www.oktylus.com/WSDL.rar. 

 

Thanks again,

Felix

  _____  

Från: Martin Gainty [mailto:mgainty@hotmail.com] 
Skickat: den 19 september 2006 16:21
Till: axis-user@ws.apache.org
Ämne: Re: problem when running wsdl2java with axis2

 

Felix-

the specific error seems to be located at 

local/Schemas/Byggnader.xsd:2:1069:

(If you could show us the relevant element contents of the file we could
assist you)

Sverige Altid-

M-

*********************************************************************
This email message and any files transmitted with it contain confidential
information intended only for the person(s) to whom this email message is
addressed.  If you have received this email message in error, please notify
the sender immediately by telephone or email and destroy the original
message without making a copy.  Thank you.

 


 

----- Original Message ----- 

From: Felix <mailto:felix.sprick@netlight.se>  Sprick 

To: axis-user@ws.apache.org 

Sent: Tuesday, September 19, 2006 9:33 AM

Subject: SV: problem when running wsdl2java with axis2

 

Hi again,

 

I have now successfully generated the XMLbeans for my xds file outside of
the AXIS2 wsdl2java command by using scomp. 

Does anybody know a convenient way to include those “manually” built
xmlbeans when invoking the wsdl2java (since I get the error-message below
when running wsdl2java with xmlbeans binding!)?

 

Thanks,

Felix

 


  _____  


Från: Felix Sprick [mailto:felix.sprick@netlight.se] 
Skickat: den 19 september 2006 09:57
Till: axis-user@ws.apache.org
Ämne: problem when running wsdl2java with axis2

 

Hi all,

 

I am using the wsdl2java tool of the nightly-build from the 14th of
September. I experience strange errors when trying to compile the wsdl file:
element seemed to be not found, which are definitely defined in the xsd…
here is the error message:

 

Z:\SGIS\WSDL>c:\Program\Apache\axis2-nightly-20060914\bin\WSDL2Java -uri
baggis.

wsdl -pn PortalSoap -ss -sd -d xmlbeans  -o ..  -g

Using AXIS2_HOME:   C:\Program\Apache\axis2

Using JAVA_HOME:    C:\Program\Java\jdk1.5.0_06

Retrieving schema at 'Schemas/PortalInterface.xsd', relative to
'file:/Z:/SGIS/W

SDL/'.

Retrieving schema at 'Brunnar.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/Port

alInterface.xsd'.

Retrieving schema at 'MessageTag.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/B

runnar.xsd'.

Retrieving schema at 'Byggnader.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/Po

rtalInterface.xsd'.

Retrieving schema at 'MessageTag.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/B

yggnader.xsd'.

Retrieving schema at 'OpenGis/gml/3.1.1/base/geometryBasic0d1d.xsd',
relative to

 'file:/Z:/SGIS/WSDL/Schemas/Byggnader.xsd'.

Retrieving schema at 'measures.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/Ope

nGis/gml/3.1.1/base/geometryBasic0d1d.xsd'.

Retrieving schema at 'units.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/OpenGi

s/gml/3.1.1/base/measures.xsd'.

Retrieving schema at 'dictionary.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/O

penGis/gml/3.1.1/base/units.xsd'.

Retrieving schema at 'gmlBase.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/Open

Gis/gml/3.1.1/base/dictionary.xsd'.

Retrieving schema at '../../../xlink/1.0.0/xlinks.xsd', relative to
'file:/Z:/SG

IS/WSDL/Schemas/OpenGis/gml/3.1.1/base/gmlBase.xsd'.

Retrieving schema at 'basicTypes.xsd', relative to
'file:/Z:/SGIS/WSDL/Schemas/O

penGis/gml/3.1.1/base/gmlBase.xsd'.

Exception in thread "main"
org.apache.axis2.wsdl.codegen.CodeGenerationException

: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

        at
org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGener

ationEngine.java:185)

        at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:32)

        at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:21)

Caused by: java.lang.RuntimeException:
java.lang.reflect.InvocationTargetExcepti

on

        at
org.apache.axis2.wsdl.codegen.extension.XMLBeansExtension.engage(XMLB

eansExtension.java:93)

        at
org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGener

ationEngine.java:140)

        ... 2 more

Caused by: java.lang.reflect.InvocationTargetException

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.

java:39)

        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces

sorImpl.java:25)

        at java.lang.reflect.Method.invoke(Method.java:585)

        at
org.apache.axis2.wsdl.codegen.extension.XMLBeansExtension.engage(XMLB

eansExtension.java:83)

        ... 3 more

Caused by: java.lang.RuntimeException: org.apache.xmlbeans.XmlException:
project

://local/Schemas/Byggnader.xsd:2:1069: error: src-resolve: element
'pointPropert

y@http://www.opengis.net/gml' not found.

        at
org.apache.axis2.xmlbeans.CodeGenerationUtility.processSchemas(CodeGe

nerationUtility.java:192)

        ... 8 more

Caused by: org.apache.xmlbeans.XmlException:
project://local/Schemas/Byggnader.x

sd:2:1069: error: src-resolve: element
'pointProperty@http://www.opengis.net/gml

' not found.

        at
org.apache.xmlbeans.impl.schema.SchemaTypeSystemCompiler.compile(Sche

maTypeSystemCompiler.java:225)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.

java:39)

        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces

sorImpl.java:25)

        at java.lang.reflect.Method.invoke(Method.java:585)

        at org.apache.xmlbeans.XmlBeans.compileXmlBeans(XmlBeans.java:667)

        at
org.apache.axis2.xmlbeans.CodeGenerationUtility.processSchemas(CodeGe

nerationUtility.java:161)

        ... 8 more

 

Any ideas on that? This is bugging me for days now, I just can’t find a way
to get the xsds running. You can find the xsds at
http://www.oktylus.com/WSDL.rar.

 

Every hint or help is highly appreciated!

Felix


Mime
View raw message