axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: [AXIS2] Calling SOAP version on WebSphere works with Release1; Possible bug in nightilies
Date Thu, 14 Sep 2006 16:19:23 GMT
Which version of websphere? jdk?

On 9/14/06, Charak, Vikas <vikas.charak@cns-inc.com> wrote:
> .aar format works fine.
>
> -----Original Message-----
> From: david.ziebol@thomson.com [mailto:david.ziebol@thomson.com]
> Sent: Thursday, September 14, 2006 12:07 PM
> To: axis-user@ws.apache.org
> Subject: RE: [AXIS2] Calling SOAP version on WebSphere works with
> Release1; Possible bug in nightilies
>
> So you have the release version of Axis2 deployed to WebSphere and it
> works with the version service in aar format or is it unpacked?
>
> Dave
>
> -----Original Message-----
> From: Charak, Vikas [mailto:vikas.charak@cns-inc.com]
> Sent: Thursday, September 14, 2006 10:41 AM
> To: axis-user@ws.apache.org
> Subject: [AXIS2] Calling SOAP version on WebSphere works with Release1;
> Possible bug in nightilies
>
> Okay!
> Atlast I was able to invoke the "version" service on websphere.
> Issue is it works with Axis2 release1.0 but not with any of the nightly
> builds. Possible bug in nightilies.
>
>
> -----Original Message-----
> From: Charak, Vikas [mailto:vikas.charak@cns-inc.com]
> Sent: Thursday, September 14, 2006 9:56 AM
> To: axis-user@ws.apache.org; dims@apache.org
> Subject: RE: NoSuchMethodError while deploying aar file on WebSphere
>
> Hi Dave/ Dims,
> I tried almost everything still same issue. REST version works but not
> SOAP version. I will write a separate email to Axis2 Designers for
> assistance.
>
> -----Original Message-----
> From: Davanum Srinivas [mailto:davanum@gmail.com]
> Sent: Wednesday, September 13, 2006 1:35 PM
> To: axis-user@ws.apache.org
> Subject: Re: NoSuchMethodError while deploying aar file on WebSphere
>
> Derek,
>
> Did you set the soap action to getMemoryStatus? try that, the
> alternative is to specify the method name in the EPR itself like you did
> for REST.
>
> thanks,
> dims
>
> On 9/13/06, VanKooten, Derek <dvankooten@beallsinc.com> wrote:
> >
> >
> >
> >
> > I seem to be having the same problem.
> >
> > I wrote a service that worked fine on the 1.0 release.
> >
> > I then read that the nightly builds had a "eager initialization"
> feature.
> >
> > So, I tried getting a nightly build and using the same aar file from
> before.
> >
> >
> >
> > I get the error
> >
> >
> >
> > Sep 13, 2006 11:20:52 AM org.apache.axis2.engine.AxisEngine
> > receiveFault
> >
> >
> >
> > INFO: Received Error Message with id
> > urn:uuid:9EF9037ADD59CB7B7D11581608519631
> >
> >
> >
> > org.apache.axis2.AxisFault: Service not found operation terminated !!
> >
> >
> >
> >             at
> >
> org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisO
> peration.java:298)
> >
> >
> >
> >             at
> >
> org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:539
> )
> >
> >
> >
> >             at
> >
> org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:473
> )
> >
> >
> >
> >             at
> >
> com.bealls.services.personalization.PersonalizationService.main(Personal
> izationService.java:53)
> >
> >
> >
> > I have tried replacing the wsdl4j.jar in lib of webshpere 6.0 with the
> one
> > that comes with axis2 nightly build.
> >
> > I have created a shared lib, added it to the class loader for the app
> > server, and set the class loader to have "Parent Last"
> >
> > The class path for my shared lib is:
> >
> >
> >
> >
> C:\Projects\axis2\WEB-INF\lib\activation-1.1.jar;C:\Projects\axis2\WEB-I
> NF\lib\annogen-0.1.0.jar;C:\Projects\axis2\WEB-INF\lib\axiom-api-SNAPSHO
> T.jar;C:\Projects\axis2\WEB-INF\lib\axiom-dom-SNAPSHOT.jar;C:\Projects\a
> xis2\WEB-INF\lib\axiom-impl-SNAPSHOT.jar;C:\Projects\axis2\WEB-INF\lib\a
> xis2-adb-codegen-SNAPSHOT.jar;C:\Projects\axis2\WEB-INF\lib\axis2-adb-SN
> APSHOT.jar;C:\Projects\axis2\WEB-INF\lib\axis2-codegen-SNAPSHOT.jar;C:\P
> rojects\axis2\WEB-INF\lib\axis2-java2wsdl-SNAPSHOT.jar;C:\Projects\axis2
> \WEB-INF\lib\axis2-jaxbri-SNAPSHOT.jar;C:\Projects\axis2\WEB-INF\lib\axi
> s2-jibx-SNAPSHOT.jar;C:\Projects\axis2\WEB-INF\lib\axis2-kernel-SNAPSHOT
> .jar;C:\Projects\axis2\WEB-INF\lib\axis2-soapmonitor-SNAPSHOT.jar;C:\Pro
> jects\axis2\WEB-INF\lib\axis2-xmlbeans-SNAPSHOT.jar;C:\Projects\axis2\WE
> B-INF\lib\backport-util-concurrent-2.1.jar;C:\Projects\axis2\WEB-INF\lib
> \commons-codec-1.3.jar;C:\Projects\axis2\WEB-INF\lib\commons-fileupload-
> 1.0.jar;C:\Projects\axis2\WEB-INF\lib\commons-httpclient-3.0.jar;C:\Proj
> ects\axis2\WEB-INF\lib\commons-logging-1.1.jar;C:\Projects\axis2\WEB-INF
> \lib\geronimo-spec-jms-1.1-rc4.jar;C:\Projects\axis2\WEB-INF\lib\jaxen-1
> .1-beta-9.jar;C:\Projects\axis2\WEB-INF\lib\jibx-run-SNAPSHOT.jar;C:\Pro
> jects\axis2\WEB-INF\lib\mail-1.4.jar;C:\Projects\axis2\WEB-INF\lib\neeth
> i-SNAPSHOT.jar;C:\Projects\axis2\WEB-INF\lib\stax-api-1.0.1.jar;C:\Proje
> cts\axis2\WEB-INF\lib\woden-SNAPSHOT.jar;C:\Projects\axis2\WEB-INF\lib\w
> sdl4j-1.5.2.jar;C:\Projects\axis2\WEB-INF\lib\wstx-asl-3.0.0.jar;C:\Proj
> ects\axis2\WEB-INF\lib\xalan-2.7.0.jar;C:\Projects\axis2\WEB-INF\lib\xbe
> an-2.1.0.jar;C:\Projects\axis2\WEB-INF\lib\xercesImpl-2.7.1.jar;C:\Proje
> cts\axis2\WEB-INF\lib\xml-apis-1.3.03.jar;C:\Projects\axis2\WEB-INF\lib\
> XmlSchema-SNAPSHOT.jar
> >
> >
> >
> > The REST version seems to work fine.
> >
> >
> http://localhost:9080/PersonalizationEngine/rest/PersonalizationServices
> /getMemoryStatus
> >
> >
> >
> > Just trying to use the epr it gives me doesn't seem to work.
> >
> >
> http://localhost:9080/PersonalizationEngine/services/PersonalizationServ
> ices
> >
> >
> >
> > I've only been playing with axis2 for a couple of days now, so, am at
> a loss
> > as to what I could do to try to troubleshoot this other than start to
> look
> > at the source code.
> >
> >
> >
> > Any help would be greatly appreciated.
> >
> > Thanks.
> >
> >
> >
> >
> >   -----Original Message-----
> > From: david.ziebol@thomson.com [mailto:david.ziebol@thomson.com]
> > Sent: Wednesday, September 13, 2006 10:31 AM
> > To: axis-user@ws.apache.org
> > Subject: RE: NoSuchMethodError while deploying aar file on WebSphere
> >
> > Setup a shared lib and put all the stuff you need in it and reference
> > the lib from you app.  WS has a tendancy to have old jars.  Setup your
>
> > appserver to "load parentlast" so the shared lib gets in first.
> >
> > Just things I've learned trying to get Axis2 in WS.
> >
> > Can you now call you services?
> >
> > Dave Ziebol
> >
> > -----Original Message-----
> > From: Charak, Vikas [mailto:vikas.charak@cns-inc.com]
> > Sent: Wednesday, September 13, 2006 9:27 AM
> > To: axis-user@ws.apache.org
> > Subject: RE: NoSuchMethodError while deploying aar file on WebSphere
> >
> > Hi ,
> > I replaced WSDL4J.jar of websphere with the WSDL4J.jar which came with
> > Axis2 and now the services are getting deployed on websphere. I am not
>
> > sure if this would affect our websphere warranty/support. I do not
> have
> > much experience on websphere but another solution could be to
> configure
> > websphere, where libraries in Axis2 module take precedence over
> > websphere. I tried setting parameter "Load parent last" for Axis2
> module
> > in Admin screen, but that did not help.
> >
> > Issue with invoking services still remains. Interestingly, I am able
> to
> > call REST version of the services but not SOAP version.
> >
> > Further investigation revealed that the SOAP endpoint in WSDL
> generated
> > by AXIS2 has "/axis2.war/services/testservice" instead of just
> > "/axis2/services/testservice". REST endpoint is fine.
> >
> > I am still doing some R&D , if I find something else I will post it.
> > Good luck to me.
> >
> > Regards,
> > Vikas
> >
> >
> >
> >
> > -----Original Message-----
> > From: david.ziebol@thomson.com [mailto:david.ziebol@thomson.com]
> > Sent: Wednesday, September 13, 2006 9:38 AM
> > To: axis-user@ws.apache.org; dims@apache.org
> > Subject: RE: NoSuchMethodError while deploying aar file on WebSphere
> >
> > Sorry, I'm relatively new to using software this bleeding edge (we are
>
> > using WebSphere after all ;-))  I normally try to post solutions to
> > issues encountered, but allas, I'm late already.
> >
> > How would I go about doing this?   I'll have to submit the stack track
> > that Vikas posted as I no longer have my software setup using the
> > nightly build.
> >
> > Dave Ziebol
> >
> > -----Original Message-----
> > From: Davanum Srinivas [mailto:davanum@gmail.com]
> > Sent: Wednesday, September 13, 2006 7:51 AM
> > To: axis-user@ws.apache.org
> > Subject: Re: NoSuchMethodError while deploying aar file on WebSphere
> >
> > David,
> >
> > Please log a JIRA bug with your problem/stack trace against nightly.
> > If we don't know about a problem, we can't fix it. can we?
> >
> > thanks,
> > dims
> >
> > On 9/13/06, david.ziebol@thomson.com <david.ziebol@thomson.com> wrote:
> > > I ran out of time to explore this issue, but
> > >
> > > Even though docs on the web note how WebSphere unpacks prior to
> use...
> > > In reality, WS6 doesn't unpack "aar" files.  So the axis2 war file
> is
> > > unpacked but the services are not.  You can see this by looking in
> the
> >
> > > services area; the aars are there and they aren't represented as
> > > folders.
> > >
> > > You could try to place the service (in unpacked form) into the
> > > \services area.  Many places won't allow a move out of dev like
> this,
> > > but at least you could determine if this is the issue.
> > >
> > > Sorry I couldn't be more helpful, as noted before, good luck, please
>
> > > post your outcome back to the mail list so others can benefit from
> > > your experiment.
> > >
> > > I'm currently trying to roll back to the ver1.0 release, and it has
> > > not been fun!
> > >
> > > Good luck
> > >
> > > Dave Ziebol
> > >
> > >
> > > -----Original Message-----
> > > From: Charak, Vikas [mailto:vikas.charak@cns-inc.com]
> > > Sent: Tuesday, September 12, 2006 3:42 PM
> > > To: axis-user@ws.apache.org
> > > Subject: RE: NoSuchMethodError while deploying aar file on WebSphere
> > >
> > > Hi Dave,
> > > Although the services are getting deployed now but when I invoke the
>
> > > service I still get "Service not found operation terminated !!"
> error
> > > on websphere .
> > > Any Idea?
> > >
> > >
> > > -----Original Message-----
> > > From: david.ziebol@thomson.com [mailto:david.ziebol@thomson.com]
> > > Sent: Tuesday, September 12, 2006 1:26 PM
> > > To: axis-user@ws.apache.org
> > > Subject: RE: NoSuchMethodError while deploying aar file on WebSphere
> > >
> > > You are using the websphere version of wsdl4j.jar rather then one of
>
> > > the newer versions that are required by Axis2.
> > >
> > > Just been down that path with nightly builds, to circumvent the
> > > websphere issue with not really unpacking aar files.  Good luck!
> > >
> > > Dave Ziebol
> > >
> > > -----Original Message-----
> > > From: Charak, Vikas [mailto:vikas.charak@cns-inc.com]
> > > Sent: Tuesday, September 12, 2006 11:19 AM
> > > To: axis-user@ws.apache.org
> > > Subject: NoSuchMethodError while deploying aar file on WebSphere
> > >
> > > Hi ,
> > > I have created a SimpleService with one method which takes in a
> string
> >
> > > and sends out a string. The SimpleService.aar deployment works fine
> on
> >
> > > Jboss But I get the following error on WebSphere.
> > > Any idea?
> > >
> > >
> > > [9/12/06 11:49:54:478 EDT] 00000028 DeploymentEng I   Invalid
> service
> > > SimpleService.aar due to java.lang.NoSuchMethodError:
> > > javax.wsdl.PortType: method
> > getExtensionAttributes()Ljava/util/Map;
> > > not found
> > >         at
> > >
> > org.apache.axis2.description.WSDL11ToAxisServiceBuilder.processPortTyp
> > > e(
> > > WSDL11ToAxisServiceBuilder.java:738)
> > >         at
> > >
> > org.apache.axis2.description.WSDL11ToAxisServiceBuilder.processBinding
> > > (W
> > > SDL11ToAxisServiceBuilder.java:412)
> > >         at
> > >
> > org.apache.axis2.description.WSDL11ToAxisServiceBuilder.populateServic
> > > e(
> > > WSDL11ToAxisServiceBuilder.java:230)
> > >         at
> > >
> > org.apache.axis2.deployment.repository.util.ArchiveReader.processWSDLF
> > > il
> > > e(ArchiveReader.java:191)
> > >         at
> > >
> > org.apache.axis2.deployment.repository.util.ArchiveReader.processWSDLs
> > > (A
> > > rchiveReader.java:304)
> > >         at
> > >
> > org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngine
> > > .j
> > > ava:513)
> > >         at
> > >
> > org.apache.axis2.deployment.repository.util.WSInfoList.update(WSInfoLi
> > > st
> > > .java:200)
> > >         at
> > >
> > org.apache.axis2.deployment.RepositoryListener.update(RepositoryListen
> > > er
> > > .java:208)
> > >         at
> > >
> > org.apache.axis2.deployment.RepositoryListener.checkServices(Repositor
> > > yL
> > > istener.java:155)
> > >         at
> > >
> > org.apache.axis2.deployment.RepositoryListener.startListener(Repositor
> > > yL
> > > istener.java:200)
> > >         at
> > >
> > org.apache.axis2.deployment.scheduler.SchedulerTask.checkRepository(Sc
> > > he
> > > dulerTask.java:61)
> > >         at
> > >
> > org.apache.axis2.deployment.scheduler.SchedulerTask.run(SchedulerTask.
> > > ja
> > > va:68)
> > >         at
> > >
> > org.apache.axis2.deployment.scheduler.Scheduler$SchedulerTimerTask.run
> > > (S
> > > cheduler.java:76)
> > >         at java.util.TimerThread.mainLoop(Timer.java:447)
> > >         at java.util.TimerThread.run(Timer.java:397)
> > >
> > >
> > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail:
> > axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> > >
> > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail:
> > axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> > >
> > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail:
> > axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> > >
> > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail:
> > axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> >
> >
> > --
> > Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service
> > Developers)
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> >
> >
>
>
> --
> Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service
> Developers)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service Developers)

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message