axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: MTOM attachments from XFire
Date Thu, 07 Sep 2006 01:16:48 GMT
Please use a nightly build of Axis2.

Options options = myStub._getServiceClient().getOptions();
   options.setProperty(org.apache.axis2.Constants.Configuration.ENABLE_MTOM,
   Boolean.TRUE);

-- dims

On 9/6/06, Jay Gillibrand <jay.gillibrand@gmail.com> wrote:
> I'm calling an XFire based web service that is using MTOM to return
> attachments. Tracing the actual HTTP request I can see the response
> looks like what I'd expect, but Axis2 fails to parse the results.
>
> The problem _seems_ to be that my Axis2 client stubs are expecting the
> attachments to be inlined as base 64 in the Soap envelope, that is,
> they are looking for a text element under the <attachmentContents>
> element in the response. The actual response has an <xop:Include>
> element there that refers to the data in another MIME section.
>
> Is there something that I need to do to get the stubs to recongnize
> MTOM attachments? The stubs appear to be completely ignorant of MTOM
> right now. The web site says clients automatically handle MTOM
> attachments...
>
> -Jay
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service Developers)

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message