axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Derek" <derek-a...@crc-corp.com>
Subject RE: wsdl stub generation(element without name attribute allowed!!!??!!?!?!)
Date Mon, 11 Sep 2006 17:39:30 GMT
If WSDL2Java is not rejecting this input (an element declared without a
name) as it should, with an informative error message, then there is a bug
in WSDL2Java as well. please file a JIRA.

Thanks.

Derek

> -----Original Message-----
> From: Anne Thomas Manes [mailto:atmanes@gmail.com] 
> Sent: Tuesday, September 05, 2006 5:20 PM
> To: axis-user@ws.apache.org
> Subject: Re: wsdl stub generation(element without name 
> attribute allowed!!!??!!?!?!)
> 
> 
> It is not valid. (Therefore it is a bug in NetBeans.) All 
> elements must have a name except the <xsd:any> element. i.e., 
> this would be
> valid:
> 
>        <xsd:element name="createFromUrl">
>                 <xsd:complexType>
>                     <xsd:sequence>
>                         <xsd:any/>
>                     </xsd:sequence>
>                 </xsd:complexType>
>             </xsd:element>
> 
> But you could not specify that the <any> element is if type 
> "xsd:anyURI".
> 
> Anne
> 
> On 9/5/06, Christian Kloner <kloner@par.univie.ac.at> wrote:
> > hi,
> >
> > A friend of mine has written a wsdl file which has in the 
> schema part 
> > elements like this:
> >
> >         <xsd:element name="createFromUrl">
> >                  <xsd:complexType>
> >                      <xsd:sequence>
> >                          <xsd:element type="xsd:anyURI"/>
> >                      </xsd:sequence>
> >                  </xsd:complexType>
> >              </xsd:element>
> >
> > as you can see, the element tag
> > <xsd:element type="xsd:anyURI"/>
> > contains no attribute "name" which is not valid if you validate 
> > against the schema. but in netbeans 5.5 with the enterprise 
> pack, you 
> > can validate whole wsdl files, and there it is completely valid to 
> > have such an element tag in it. so i am just wondering if 
> it is valid 
> > or not (bug of netbeans???). the stubs generated from the 
> above code 
> > fragement produce the following output:
> >
> > <createFromUrl xmlns="http://aurigafactory.gridminer.org">
> > <null xmlns=""> 
> > 
> http://www.localhost:8080/auriga/FactoryInstanceWorkflowEPRSecond.xml
> > </null>
> > </createFromUrl>
> >
> > So is this allowed/valid? thanks in advance.
> > chris
> >
> > 
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message