axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anne Thomas Manes" <atma...@gmail.com>
Subject Re: Axis 1.3: Axis Interoperability issue with .net
Date Tue, 01 Aug 2006 14:00:20 GMT
I thought it was fixed in 1.4, but recent postings to the list make
think that it wasn't.
The bug is that Axis uses the same element name for both the array
wrapping element and the array items. e.g.,

<arrayofFoo>
  <arrayofFoo>...</arrayofFoo>
  <arrayofFoo>...</arrayofFoo>
</arraryofFoo>

instead of

<arrayofFoo>
   <foo>...</foo>
   <foo>...</foo>
</arrayofFoo>

One way to work around this problem is to use unwrapped arrays.

Anne

On 7/31/06, Pradeep Reddy <deepgun74@gmail.com> wrote:
> Anne,
>
> Thanks for your quick reply.
>
> I looked up JIRA and found this issue.
> http://issues.apache.org/jira/browse/AXIS-2267
> PublishedAsset is a subclass but I don't have any mixed type arrays. So this
> might not be the bug that you are referring to.
> I applied the patch to this issue to the
> org.apache.axis.encoding.SerializationContext and ran into
> the same issue again.
>
> Was this bug fixed in axis 1.4?
>
> Regards,
> Pradeep
>
>
>  On 7/31/06, Anne Thomas Manes <atmanes@gmail.com> wrote:
> >
>  This is a bug in the way Axis 1.3 manages arrays.
>
>
> On 7/31/06, Pradeep Reddy <deepgun74@gmail.com> wrote:
> > Hi all,
> > I am using Axis 1.3.
> >
> > My webservice is sending back a response that is similar to this for
> couple
> > of contained objects.
> > ....
> > <iv_contactInfo>
> > ...
> > <iv_contactInfo>
> > ...
> >
> > However, .NET is expecting
> > ..
> > <ContactInfo>
> > <iv_contactInfo>
> > ....
> > <iv_contactInfo>
> > <ContactInfo>
> > ..
> > and returns null values for ContactInfo objects.
> >
> > ContactInfo is the type of object that client builds after recieving the
> > response.
> > Please note that Contactinfo is returned as part of a larger object
> > PublishedAsset.
> >
> > PublishedAsset
> >    -- ArrayOfAssetContact
> >           --AssetContact
> >               ---ContactInfo
> >
> > Has anyone seen this issue before?  Any help would be greatly appreciated.
> >
> > Thanks,
> > Pradeep
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message