axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zolv <z...@o2.pl>
Subject [axis2] First 3 and last byte in messages
Date Fri, 04 Aug 2006 08:13:44 GMT
Hi.

I created a simple service (implementation is trivial) and 2 clients for them.
One client uses axis2 classes to manage messages exchange and the second one using HttpURLConnection
to do it (hardcoded) without any axis classes.
I use TCPMon (from axis (not axis2)) to wathing what is happening.

And.

First client (with axis2 classes) works great. But when I send the same message using second
client I got an errors:
on client side:
IOException Server returned HTTP response code: 500 for URL(...)
on server side (main/first error):
"SOAPEnvelope must contain a body element which is either first or second child element of
the SOAPEnvelope."

And now

I noticed, that client that use axis2 classes sends additional bytes in message:

fb
<?xml version='1.0' encoding='UTF-8'?>
(...message content...)
</soapenv:Envelope>0

and when I put this chars ("fb\n" on beginning and "0" in the end) to the emessage in second
client, everything works fine.

Surprisingly, when I change "fb" to f.e. "aa" it works too, but if I put "xx"/"00" it's not
(is it hex or sth?).
And my question is:

What are this bytes?
(I can send an clients/server implementation if needed)

Greetings
zolv

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message