axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruchith Fernando" <ruchith.ferna...@gmail.com>
Subject Re: [Axis2] making it work
Date Thu, 31 Aug 2006 06:47:04 GMT
On 8/31/06, Jaimin <jaimin.mehta@transformaticsgroup.com> wrote:
>
>
> Hi Ruchith,
>
> I tried as you suggested below, but the problem continues.
>
> The service is "version", not "getVersion".
> The operation in that service I want to invoke is "getVersion"

In Axis2 we do allow one to use a URL to point upto the operation as
well. Therefore
http://localhost:8080/axis2/services/version/getVersion should work !

> The syntactic convention to invoke an operation via an URL, which works well
> for all cases and which I follow, is
>
> <EPR>"?method="<operationName>"&"<parameterName>=<parameterValue>"&"...
>
> The following works to obtain wsdl of "version" works.  But the latter to
> invoke "getVersion" gives me error.
>     localhost:8080/axis2/services/version?wsdl
>
>     localhost:8080/axis2/services/version?method=getVersion
> The same EPR for axis1.x (replacing "axis2" with "axis") does not give me
> error.

As you can see in the wsdl of the version service the valid address is
http://localhost:8080/axis2/services/version

I think the above case worked because Axis2 ignored the
"?method=getVersion" part.

Thanks,
Ruchith

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message