axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Derek" <derek-a...@crc-corp.com>
Subject RE: [AXIS2] nightly build problem when parsing xml stream
Date Tue, 15 Aug 2006 19:24:29 GMT
Although I agree with what Ajith said, below, I still encourage you
(Alistair) to file a JIRA about the fact that Axis does not log the error.
Axis should not ever fail without logging an error message. Even if the
problem was due to misconfiguration, Axis should leave an informative error
message in the log file saying so. (It sounds like a static initialization
block in the code (or a static variable initializer) is missing a try..catch
block that would ensure that any thrown exceptions get logged.)

Derek

> -----Original Message-----
> From: Ajith Ranabahu [mailto:ajith.ranabahu@gmail.com] 
> Sent: Monday, August 14, 2006 1:20 PM
> To: axis-user@ws.apache.org; derek-axis@crc-corp.com
> Subject: Re: [AXIS2] nightly build problem when parsing xml stream
> 
> 
> Hi,
> Try using the generated ant build to build your aar file. The 
> ant build inserts the necessary files into the aar file and 
> you should not have a problem!
> 
> Ajith
> 
> On 8/14/06, Derek <derek-axis@crc-corp.com> wrote:
> > Alistair:
> >
> > Please file a JIRA indicating that the error that occurs in 
> this case 
> > doesn't get logged (and it should!)
> >
> > Thanks.
> >
> > Derek
> >
> > > -----Original Message-----
> > > From: Alistair Young [mailto:alistair@smo.uhi.ac.uk]
> > > Sent: Thursday, August 10, 2006 6:37 AM
> > > To: axis-user@ws.apache.org
> > > Subject: Re: [AXIS2] nightly build problem when parsing xml stream
> > >
> > >
> > > aha! handy thing a debugger coz the exception doesn't 
> make it into 
> > > the log.
> > >
> > > schemaorg_apache_xmlbeans.system.sA6973D16021071091ABD334B25B9
> > > A53E.TypeS
> > > ystemHolder was missing.
> > >
> > > sorted
> > >
> > > Alistair
> > >
> > > On 10 Aug 2006, at 13:11, Alistair Young wrote:
> > >
> > > > Hi there,
> > > >
> > > > Is there anything obvious that might be causing these? 
> They occur 
> > > > when a MessageReceiver (generated by WSDL2Java) is 
> trying to do a 
> > > > Factory.newInstance 
> > > > 
> (org.apache.axiom.om.OMElement.getXMLStreamReaderWithoutCaching(),
> > > > new org.apache.xmlbeans.XmlOptions().setLoadAdditionalNamespaces
> > > > (extraNamespaces))
> > > >
> > > > there's no other info in the logs.
> > > >
> > > > first attempt at calling the service via stub:
> > > > SEVERE: java.lang.ExceptionInInitializerError
> > > >
> > > > next attempt:
> > > > SEVERE: java.lang.NoClassDefFoundError
> > > > INFO: org.apache.axis2.AxisFault: null; nested exception is:
> > > >         com.ctc.wstx.exc.WstxIOException: null
> > > >
> > > > thanks,
> > > >
> > > > Alistair
> > > >
> > > >
> > > >
> > > >
> > > >
> > > 
> --------------------------------------------------------------------
> > > -
> > > > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > > >
> > >
> > >
> > > 
> --------------------------------------------------------------------
> > > -
> > > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> >
> >
> >
> > 
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
> 
> 
> -- 
> Ajith Ranabahu
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message