axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wan Kaveevivitchai" <wan1...@hotmail.com>
Subject Re: [Axis2 v1.0] security sample problem
Date Tue, 18 Jul 2006 13:18:09 GMT

thank you very much, Ruchith

Wan

>From: "Ruchith Fernando" <ruchith.fernando@gmail.com>
>Reply-To: axis-user@ws.apache.org
>To: axis-user@ws.apache.org
>Subject: Re: [Axis2 v1.0] security sample problem
>Date: Tue, 18 Jul 2006 18:26:23 +0530
>
>Hi Wan,
>
>The value of the repo should be the "samples/security/client_repo" dir
>in the axis2-std-bin distro.
>
>when you are running this in Eclipse your first (and only) "Program
>Argument" should be
>"{your_axis2_std_bin_distro_dir_}/samples/security/client_repo" and
>also there should be the following VM argument:
>-Daxis2.xml={your_axis2_std_bin_distro_dir_}/samples/security/client_repo/conf/axis2.xml
>
>You can find the place to enter these values in the "Arguments" tab of
>your run configuration.
>
>Thanks,
>Ruchith
>
>On 7/18/06, Wan Kaveevivitchai <wan1551@hotmail.com> wrote:
>>Thank you Ruchith,
>>
>>     it works now with ant.
>>     i have another question for you, what should it be the value for repo 
>>if
>>i want to run this sample on eclipse?
>>
>>     do i need to set up VM environment on eclipse as well? if yes, how?
>>     thanks,
>>
>>      Wan
>>
>>
>> >From: "Ruchith Fernando" <ruchith.fernando@gmail.com>
>> >Reply-To: axis-user@ws.apache.org
>> >To: axis-user@ws.apache.org
>> >Subject: Re: [Axis2 v1.0] security sample problem
>> >Date: Tue, 18 Jul 2006 17:18:01 +0530
>> >
>> >If you are using the latest SNAPSHOT distros (in your original mail
>> >you mentioned that you are using the July 17 build), then please use :
>> >http://people.apache.org/repository/ws-commons/jars/axiom-dom-SNAPSHOT.jar
>> >
>> >If you are using Axis2 1.0 release then axiom-dom-1.0.jar is fine.
>> >
>> >Thanks,
>> >Ruchith
>> >
>> >On 7/18/06, Wan Kaveevivitchai <wan1551@hotmail.com> wrote:
>> >>
>> >>Dear Ruchith,
>> >>
>> >>        I had axiom-dom-1.0.jar in my WEB-INF/lib. Is it different from
>> >>axiom-dom-SNAPSHOT.jar?
>> >>
>> >>       where can i find and download axiom-dom-SNAPSHOT.jar?
>> >>
>> >>       thank you,
>> >>
>> >>        Wan
>> >>
>> >> >From: "Ruchith Fernando" <ruchith.fernando@gmail.com>
>> >> >Reply-To: axis-user@ws.apache.org
>> >> >To: axis-user@ws.apache.org
>> >> >Subject: Re: [Axis2 v1.0] security sample problem
>> >> >Date: Tue, 18 Jul 2006 16:54:33 +0530
>> >> >
>> >> >Hi,
>> >> >
>> >> >First of all your server side is missing the axiom-dom-SNAPSHOT.jar
>> >> >and you see the client side error due to the SOAP fault sent in the
>> >> >response as a mime multipart message is malformed.
>> >> >
>> >> >Please add the axiom-dom-SNAPSHOT.jar in to the WEB-INF/lib dir,
>> >> >restart tomcat (or do the equivalent in your container) and try 
>>again.
>> >> >
>> >> >The reason for the error when you are running with eclipse is that 
>>you
>> >> >seem to have given the wrong client-repo, hence axis2 cannot find the
>> >> >modules.
>> >> >
>> >> >Thanks,
>> >> >Ruchith
>> >> >
>> >> >On 7/18/06, Wan Kaveevivitchai <wan1551@hotmail.com> wrote:
>> >> >>hi all,
>> >> >>
>> >> >>         i have some problem about running security sample.
>> >> >>         i have tried to run it with many different version of axis2
>> >> >>releases
>> >> >>and i still have the same problem with the latest version release

>>July
>> >>17.
>> >> >>
>> >> >>         i have ran build.xml for security sample and the result
is
>> >> >>
>> >> >>alice3@islay:~/axis2-std-SNAPSHOT-bin/samples/security> ant
>> >> >>Buildfile: build.xml
>> >> >>
>> >> >>securitySample:
>> >> >>      [java] 18.07.2006 12:02:23
>> >> >>org.apache.axis2.deployment.DeploymentEngine
>> >> >>prepareRepository
>> >> >>      [java] INFO: no services directory found , new one created
>> >> >>      [java] 18.07.2006 12:02:23
>> >> >>org.apache.axis2.deployment.DeploymentEngine
>> >> >>doDeploy
>> >> >>      [java] INFO: Deploying module : addressing-1.0
>> >> >>      [java] 18.07.2006 12:02:24
>> >> >>org.apache.axis2.deployment.DeploymentEngine
>> >> >>doDeploy
>> >> >>      [java] INFO: Deploying module : rampart-1.0
>> >> >>      [java] org.apache.axis2.AxisFault: WSDoAllReceiver: Error
in
>> >> >>converting
>> >> >>to Document; nested exception is:
>> >> >>      [java]     org.apache.ws.security.WSSecurityException: Error

>>in
>> >> >>converting SOAP Envelope to Document; nested exception is:
>> >> >>      [java]     org.apache.axiom.om.OMException:
>> >> >>java.lang.IllegalStateException: Current state not START_ELEMENT
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.security.WSDoAllReceiver.processMessage(WSDoAllReceiver.java:130)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.security.handler.WSDoAllHandler.invoke(WSDoAllHandler.java:82)
>> >> >>      [java]     at
>> >>org.apache.axis2.engine.Phase.invoke(Phase.java:380)
>> >> >>      [java]     at
>> >> >>org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:523)
>> >> >>      [java]     at
>> >> >>org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:492)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:362)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:280)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:538)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:472)
>> >> >>      [java]     at sample.security.Client.main(Client.java:58)
>> >> >>      [java] Caused by: org.apache.ws.security.WSSecurityException:
>> >>Error
>> >> >>in
>> >> >>converting SOAP Envelope to Document; nested exception is:
>> >> >>      [java]     org.apache.axiom.om.OMException:
>> >> >>java.lang.IllegalStateException: Current state not START_ELEMENT
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.security.util.Axis2Util.getDocumentFromSOAPEnvelope(Axis2Util.java:126)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.security.WSDoAllReceiver.processMessage(WSDoAllReceiver.java:128)
>> >> >>      [java]     ... 9 more
>> >> >>      [java] Caused by: org.apache.axiom.om.OMException:
>> >> >>java.lang.IllegalStateException: Current state not START_ELEMENT
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:206)
>> >> >>      [java]     at
>> >> >>org.apache.axiom.om.impl.llom.OMNodeImpl.build(OMNodeImpl.java:298)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axis2.security.util.Axis2Util.getDocumentFromSOAPEnvelope(Axis2Util.java:90)
>> >> >>      [java]     ... 10 more
>> >> >>      [java] Caused by: java.lang.IllegalStateException: Current

>>state
>> >>not
>> >> >>START_ELEMENT
>> >> >>      [java]     at
>> >> 
>> >>com.ctc.wstx.sr.BasicStreamReader.getAttributeCount(BasicStreamReader.java:559)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axiom.om.impl.builder.StAXBuilder.processAttributes(StAXBuilder.java:141)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axiom.om.impl.mtom.MTOMStAXSOAPModelBuilder.createOMElement(MTOMStAXSOAPModelBuilder.java:142)
>> >> >>      [java]     at
>> >> 
>> >>org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:132)
>> >> >>      [java]     ... 12 more
>> >> >>
>> >> >>BUILD SUCCESSFUL
>> >> >>Total time: 8 seconds
>> >> >>
>> >> >>and at the server side, i got
>> >> >>SCHWERWIEGEND: java.lang.NoClassDefFoundError:
>> >> >>org/apache/axiom/om/impl/dom/jaxp/DocumentBuilderFactoryImpl
>> >> >>
>> >> >>that was run by ant. And i also run it with eclipse environment
and 
>>i
>> >>got
>> >> >>the following result
>> >> >>
>> >> >>18.07.2006 11:12:49 org.apache.axis2.deployment.DeploymentEngine
>> >> >>loadFromClassPath
>> >> >>INFO: Module validation failed  Trying to engage a module which
is 
>>not
>> >> >>available : addressing
>> >> >>org.apache.axis2.deployment.DeploymentException: Trying to engage
a
>> >>module
>> >> >>which is not available : addressing; nested exception is:
>> >> >>         org.apache.axis2.AxisFault: Trying to engage a module which

>>is
>> >> >>not
>> >> >>available : addressing
>> >> >>         at
>> >> 
>> >>org.apache.axis2.deployment.DeploymentEngine.loadFromClassPath(DeploymentEngine.java:134)
>> >> >>         at
>> >> 
>> >>org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(FileSystemConfigurator.java:122)
>> >> >>         at
>> >> 
>> >>org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:56)
>> >> >>         at
>> >> 
>> >>org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:135)
>> >> >>         at sample.security.Client.main(Client.java:57)
>> >> >>Caused by: org.apache.axis2.AxisFault: Trying to engage a module

>>which
>> >>is
>> >> >>not available : addressing
>> >> >>         at
>> >> 
>> >>org.apache.axis2.engine.AxisConfiguration.engageModule(AxisConfiguration.java:330)
>> >> >>         at
>> >> 
>> >>org.apache.axis2.deployment.DeploymentEngine.engageModules(DeploymentEngine.java:744)
>> >> >>         at
>> >> 
>> >>org.apache.axis2.deployment.DeploymentEngine.loadFromClassPath(DeploymentEngine.java:130)
>> >> >>         ... 4 more
>> >> >>
>> >> >>          on eclipse i have also set VM environment to be the same

>>as
>> >> >>specified in build.xml but from the tcpmon, i can see the message
>> >>sending
>> >> >>by
>> >> >>ant was encrypted. however, the other one which send via eclipse
was
>> >>not
>> >> >>encrypted.
>> >> >>
>> >> >>         Any idea, what's wrong?
>> >> >>
>> >> >>         your help is greatly appreciated
>> >> >>
>> >> >>         Wan
>> >> >>
>> >> >>
>> >> >>
>> >> 
>> >>---------------------------------------------------------------------
>> >> >>To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>> >> >>For additional commands, e-mail: axis-user-help@ws.apache.org
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >> >--
>> >> >www.ruchith.org
>> >> >
>> >> >---------------------------------------------------------------------
>> >> >To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>> >> >For additional commands, e-mail: axis-user-help@ws.apache.org
>> >> >
>> >>
>> >>
>> >>
>> >>---------------------------------------------------------------------
>> >>To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>> >>For additional commands, e-mail: axis-user-help@ws.apache.org
>> >>
>> >>
>> >
>> >
>> >--
>> >www.ruchith.org
>> >
>> >---------------------------------------------------------------------
>> >To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>> >For additional commands, e-mail: axis-user-help@ws.apache.org
>> >
>>
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>>For additional commands, e-mail: axis-user-help@ws.apache.org
>>
>>
>
>
>--
>www.ruchith.org
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>For additional commands, e-mail: axis-user-help@ws.apache.org
>



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message