axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wan Kaveevivitchai" <wan1...@hotmail.com>
Subject Re: axis2 v1.0 security sample, cannot see addressing.mar
Date Mon, 03 Jul 2006 06:47:12 GMT

hi all,

     I am trying to deploy and test the security example, i have done 
everything that states in README.txt. but i got the error when i ran 
build.xml. And also i have checked in axis2.xml the setting about addressing 
module was there, and also there is the addressing.mar in the module 
directory.

Please point out what is the problem.

Sathita

Buildfile: build.xml

securitySample:
      [java] log4j:WARN No appenders could be found for logger
(org.apache.axiom.om.impl.builder.StAXOMBuilder).
      [java] log4j:WARN Please initialize the log4j system
properly.
      [java] org.apache.axis2.AxisFault: Trying to engage a module
which is not available : addressing
      [java]     at
org.apache.axis2.engine.AxisConfiguration.engageModule(AxisConfiguration.java:291)
     [java]  at
org.apache.axis2.deployment.DeploymentEngine.engageModules(DeploymentEngine.java:743)
     [java]     at
org.apache.axis2.deployment.FileSystemConfigurator.engageGlobalModules(FileSystemConfigurator.java:128)
      [java]     at
org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:41)
      [java]     at
org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:90)
      [java]     at sample.security.Client.main(Client.java:48)

> >>BUILD SUCCESSFUL
> >>Total time: 2 seconds

>From: "Wan Kaveevivitchai" <wan1551@hotmail.com>
>Reply-To: axis-user@ws.apache.org
>To: axis-user@ws.apache.org
>Subject: Re: axis2 v1.0 security sample
>Date: Fri, 30 Jun 2006 23:02:21 +0000
>
>
>
>thank you,
>
>i think i have done that, i dropped the .mar file into modules directory 
>and also added the line about module in axis2.xml file.
>
>can any other thing cause the problem?
>
>thanks once again
>
>Sathita
>
>
>
>
>
>
>From:  "Ruchith Fernando" <ruchith.fernando@gmail.com>
>Reply-To:  axis-user@ws.apache.org
>To:  axis-user@ws.apache.org
>Subject:  Re: axis2 v1.0 security sample
>Date:  Fri, 30 Jun 2006 20:02:11 +0530
> >Hi Sathita,
> >
> >You have to copy the modules (.mar files) into the
> >"client_repo/modules/" directory in the security sample directory.
> >
> >Please follow the instructions in the README.txt file in the
> >security
> >sample's directory.
> >
> >Thanks,
> >Ruchith
> >
> >On 6/30/06, Wan Kaveevivitchai <wan1551@hotmail.com> wrote:
> >>hi all,
> >>
> >>        I am trying to run the security sample provided. When i run
> >>ant as
>in
> >>README.txt, i got this error:
> >>
> >>Buildfile: build.xml
> >>
> >>securitySample:
> >>      [java] log4j:WARN No appenders could be found for logger
> >>(org.apache.axiom.om.impl.builder.StAXOMBuilder).
> >>      [java] log4j:WARN Please initialize the log4j system
> >>properly.
> >>      [java] org.apache.axis2.AxisFault: Trying to engage a module
> >>which is
> >>not available : addressing
> >>      [java]     at
> >>org.apache.axis2.engine.AxisConfiguration.engageModule(AxisConfiguration.java:291)
> >>      [java]    at
> >>org.apache.axis2.deployment.DeploymentEngine.engageModules(DeploymentEngine.java:743)
> >>      [java]     at
> >>org.apache.axis2.deployment.FileSystemConfigurator.engageGlobalModules(FileSystemConfigurator.java:128)
> >>      [java]     at
> >>org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:41)
> >>      [java]     at
> >>org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:90)
> >>      [java]     at sample.security.Client.main(Client.java:48)
> >>
> >>BUILD
>SUCCESSFUL
> >>Total time: 2 seconds
> >>
> >>   It really said nothing about the rampart but it said that there
> >>is no
> >>addressing module. Is the addressing module suppose to be provided
> >>there by
> >>default? I have checked the modules directory, and the
> >>addressing.mar is
> >>there, as well as in the axis2.xml, there is a line that indicate
> >>the
> >>existance of addressing module.
> >>
> >>please help
> >>
> >>Sathita
> >>
> >>
> >>
> >>---------------------------------------------------------------------
> >>To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >>For additional commands, e-mail:
>axis-user-help@ws.apache.org
> >>
> >>
> >
> >
> >--
> >www.ruchith.org
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >For additional commands, e-mail: axis-user-help@ws.apache.org
> >
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>For additional commands, e-mail: axis-user-help@ws.apache.org
>



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message