axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruchith Fernando" <ruchith.ferna...@gmail.com>
Subject Re: axis2 v1.0 security sample
Date Tue, 04 Jul 2006 08:43:12 GMT
Did you configure the service in axis2 within Tomcat as mentioned in
the README.txt?

Thanks,
Ruchith

On 7/4/06, Wan Kaveevivitchai <wan1551@hotmail.com> wrote:
> This is what i got right now.
>
> alice3@islay:~/axis2-std-1.0-bin/samples/security> ant securitySample
> Buildfile: build.xml
>
> securitySample:
>      [java] log4j:WARN No appenders could be found for logger
> (org.apache.axiom.om.impl.builder.StAXOMBuilder).
>      [java] log4j:WARN Please initialize the log4j system properly.
>      [java] org.apache.axis2.AxisFault: WSDoAllReceiver: Error in converting
> to Document; nested exception is:
>      [java]     org.apache.ws.security.WSSecurityException: Error in
> converting SOAP Envelope to Document; nested exception is:
>      [java]     org.apache.axiom.om.OMException:
> java.lang.IllegalStateException: Current state not START_ELEMENT
>      [java]     at
> org.apache.axis2.security.WSDoAllReceiver.processMessage(WSDoAllReceiver.java:130)
>      [java]     at
> org.apache.axis2.security.handler.WSDoAllHandler.invoke(WSDoAllHandler.java:82)
>      [java]     at org.apache.axis2.engine.Phase.invoke(Phase.java:381)
>      [java]     at
> org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:473)
>      [java]     at
> org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:445)
>      [java]     at
> org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:355)
>      [java]     at
> org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:279)
>      [java]     at
> org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:457)
>      [java]     at
> org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:399)
>      [java]     at sample.security.Client.main(Client.java:58)
>      [java] Caused by: org.apache.ws.security.WSSecurityException: Error in
> converting SOAP Envelope to Document; nested exception is:
>      [java]     org.apache.axiom.om.OMException:
> java.lang.IllegalStateException: Current state not START_ELEMENT
>      [java]     at
> org.apache.axis2.security.util.Axis2Util.getDocumentFromSOAPEnvelope(Axis2Util.java:126)
>      [java]     at
> org.apache.axis2.security.WSDoAllReceiver.processMessage(WSDoAllReceiver.java:128)
>      [java]     ... 9 more
>      [java] Caused by: org.apache.axiom.om.OMException:
> java.lang.IllegalStateException: Current state not START_ELEMENT
>      [java]     at
> org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:206)
>      [java]     at
> org.apache.axiom.om.impl.llom.OMNodeImpl.build(OMNodeImpl.java:298)
>      [java]     at
> org.apache.axis2.security.util.Axis2Util.getDocumentFromSOAPEnvelope(Axis2Util.java:90)
>      [java]     ... 10 more
>      [java] Caused by: java.lang.IllegalStateException: Current state not
> START_ELEMENT
>      [java]     at
> com.ctc.wstx.sr.BasicStreamReader.getAttributeCount(BasicStreamReader.java:559)
>      [java]     at
> org.apache.axiom.om.impl.builder.StAXBuilder.processAttributes(StAXBuilder.java:141)
>      [java]     at
> org.apache.axiom.om.impl.mtom.MTOMStAXSOAPModelBuilder.createOMElement(MTOMStAXSOAPModelBuilder.java:142)
>      [java]     at
> org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:132)
>      [java]     ... 12 more
>
> BUILD SUCCESSFUL
> Total time: 8 seconds
>
>        I have put addressing-1.0.mar and rampart-1.0.mar into
> client_repo/modules/ as well
>        Please help,
>
>         Sathita
>
>
>
> >From: "Ruchith Fernando" <ruchith.fernando@gmail.com>
> >Reply-To: axis-user@ws.apache.org
> >To: axis-user@ws.apache.org
> >Subject: Re: axis2 v1.0 security sample
> >Date: Tue, 4 Jul 2006 14:00:07 +0530
> >
> >Hi Sathita,
> >
> >On 7/1/06, Wan Kaveevivitchai <wan1551@hotmail.com> wrote:
> >>
> >>
> >>
> >>thank you,
> >>
> >>i think i have done that, i dropped the .mar file into modules directory
> >>and
> >>also added the line about module in axis2.xml file.
> >>
> >>can any other thing cause the problem?
> >
> >If you follow all the steps in the README.txt in order it should work.
> >The original error you posted says that you have not copied the
> >addressing-1.0.mar file into the  client_repo/modules/ directory.
> >
> >Thanks,
> >Ruchith
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >For additional commands, e-mail: axis-user-help@ws.apache.org
> >
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
www.ruchith.org

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message