axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jorge Ortiz Hinojosa" <t-jor...@microsoft.com>
Subject [Axis2] Trouble running Security sample client on Windows XP
Date Sat, 15 Jul 2006 02:53:09 GMT
I'm trying to run Axis2 as a webapp on Tomcat5.5 on WinXP SP2 with
JDK1.5. Specifically, I'm trying to run the "security" sample client and
service that come with the Axis2 distribution (under samples/security/).

 

The service shows up just fine in my list of services on
http://localhost:8080/axis2/services/listServices

 

But when I try to run the client, I get the following:

 

***

 

C:\axis2\samples\security>ant securitySample

Buildfile: build.xml

 

securitySample:

     [java] log4j:WARN No appenders could be found for logger
(org.apache.axiom.om.impl.builder.StAXOMBuilder).

     [java] log4j:WARN Please initialize the log4j system properly.

     [java] Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/xml/utils/URI$MalformedURIException

     [java]     at
org.apache.ws.security.message.WSSecSignature.prepare(WSSecSignature.jav
a:336)

     [java]     at
org.apache.ws.security.message.WSSecSignature.build(WSSecSignature.java:
643)

     [java]     at
org.apache.ws.security.action.SignatureAction.execute(SignatureAction.ja
va:54)

     [java]     at
org.apache.ws.security.handler.WSHandler.doSenderAction(WSHandler.java:1
91)

     [java]     at
org.apache.axis2.security.WSDoAllSender.processMessage(WSDoAllSender.jav
a:181)

     [java]     at
org.apache.axis2.security.handler.WSDoAllHandler.invoke(WSDoAllHandler.j
ava:82)

     [java]     at org.apache.axis2.engine.Phase.invoke(Phase.java:381)

     [java]     at
org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:473)

     [java]     at
org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:572)

     [java]     at
org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOper
ation.java:328)

     [java]     at
org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisO
peration.java:279)

     [java]     at
org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:457
)

     [java]     at
org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:399
)

     [java]     at sample.security.Client.main(Client.java:58)

     [java] Java Result: 1

 

BUILD SUCCESSFUL

Total time: 2 seconds

C:\axis2\samples\security>

 

***

 

Any idea what's wrong?

 

Thanks,

 

Jorge


Mime
View raw message