axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabien Couble" <fabien.couble.exte...@capgemini.com>
Subject [AXIS 2] engage Ws-Addressing at the client side
Date Tue, 04 Jul 2006 09:35:11 GMT

I'm trying to implement a client using WS-Addressing but the command "sender.engageModule(new
QName(Constants.MODULE_ADDRESSING));" raises an exception like this:
org.apache.axis2.AxisFault: Module not found

at org.apache.axis2.description.AxisService.engageModule(AxisService.java:395)

at org.apache.axis2.client.ServiceClient.engageModule(ServiceClient.java:279)

at userguide.clients.EchoNonBlockingDualClient.main(EchoNonBlockingDualClient.java:66)



As you can see, I have a problem to engage the module at the client side.

I tried to put the module (addressing.mar) in the same directory of my client but nothing!

I also try to put the following command: 

ConfigurationContext configContext = ConfigurationContextFactory.createConfigurationContextFromFileSystem("C:/Documents
and Settings/fcouble/Bureau/axis2-std-1.0-bin", null);

But nothing happens... always the same error

An idea, please,



Fabien


This message contains information that may be privileged or confidential and is the property
of the Capgemini Group. It is intended only for the person to whom it is addressed. If you
are not the intended recipient,  you are not authorized to read, print, retain, copy, disseminate,
 distribute, or use this message or any part thereof. If you receive this  message in error,
please notify the sender immediately and delete all  copies of this message.

Mime
View raw message