axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vineet_Vashi...@abercrombie.com
Subject RE: https with WS
Date Fri, 23 Jun 2006 14:13:04 GMT
Ben, thanks for the reply. Yours was one of the posts that I had read 
before eventually posting the email. The article you referenced was one 
that I had worked with in the past.

I am still very unclear on how the whole SSL works with WebServices. The 
axis 1.1 is working but I am not sure if I even set up all the 
certificates etc. correctly. it just somehow works. As far as the Axis 2.0 
client goes, I am beginning to think it might be something unrelated to 
authentication and certificates altogether.

I just get a transport error - unknown from axis. I have tried a few 
things to try to give it more information (changing axis2.xml) but they 
have had no impact. 

Looking at the actuall SOAP requests generated, I can see that axis1.1 
uses HTTP 1.0 and Axis2.0 uses HTTP1.1 . Do you think that could cause a 
problem?

The person who hosts the WS says he is receiving no traffic from me 
whatsoever. When I change the endpoint to oint to a generic https site, 
the message that I get back shows me that I WAS able to at least reach 
that generic https site. Somehow the WS host never sees anything at all.




"Ben Ethridge" <bethridge@UpToDate.com> 
06/23/2006 10:05 AM
Please respond to
axis-user@ws.apache.org


To
<axis-user@ws.apache.org>
cc

Subject
RE: https with WS






Hi, Vineet. Did you see my post from a couple of days ago on this?
 
 

From: Vineet_Vashisht@abercrombie.com 
[mailto:Vineet_Vashisht@abercrombie.com] 
Sent: Friday, June 23, 2006 7:54 AM
To: axis-user@ws.apache.org
Subject: https with WS
 
Hello All, 
        I am unable to get the https to work with WS. I have followed many 
posts and other srticles on the web and I have tried just about all they 
have suggested but am still unsuccessful. I was wondering if someone could 
help me out. 
I am using JDK1.4 with Axis2 (1.0) generated client (WSDL2Java) to access 
an https WS hosted by a third party vendor. 
Currently I am getting a sun.security.validator.ValidatorException: No 
trusted certificate found 
Any help would be appreciated. 
On a sidenote, I was able to get this to work using Axis 1.1 client stub 
(WSDL2Java) with JDK1.3 (inside WebSphere Studio) 
Vineet
This e-mail message may contain confidential and/or privileged 
information. If you are 
not an addressee or otherwise authorized to receive this message, you 
should not use, 
copy, disclose or take any action based on this e-mail or any information 
contained in the 
message. If you have received this material in error, please advise the 
sender immediately 
by reply e-mail and delete this message. 

Thank you.


Mime
View raw message