axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McCauley, Tim" <TMcCau...@c-cor.com>
Subject RE: AxisServlet returns "And now... Some Services" only (blank page)
Date Thu, 15 Jun 2006 17:27:08 GMT
Not sure if this will help.  I just ran into the same problem and move the saaj.jar and jaxrpc.jar
to the TOMCAT_HOME/common/lib/endorsed.  I read in the install documentation for Axis that
this might be necessary for Tomcat 4 and Java 1.4 so I tried it and it worked.  I am running
Tomcat 5.0.28 and Java 1.4.2.08 on a windows box.
 
Tim

-----Original Message-----
From: Ben Ethridge [mailto:bethridge@UpToDate.com]
Sent: Thursday, June 15, 2006 1:19 PM
To: axis-user@ws.apache.org
Subject: AxisServlet returns "And now... Some Services" only (blank page)



Hi.

 

I've spent several hours now, on google and yahoo attempting to track down why AxisServlet
is returning just a blank page with "And now... Some Services" on it. Looking at the logs
in tomcat shows no error (or warning or info) about what might be the problem. Google was
uncharacteristically useless on this one, but I found some hints on Yahoo using a search term
of:

 

"And now... Some Services" blank

 

This was the best hint so far:

 

http://java2.5341.com/msg/8859.html

 

My symptoms are exactly as stated in the above. I can remove all the packages and classes
in my web service deployment and I then get more "reasonable" errors, i.e. ClassNotFoundException
and such.  Also, I can remove the offending <service> entirely from the server-config.wsdd,
at which point Axis behaves normally, showing the usual set of installed Axis services when
I call the AxisServlet, so it's clearly a problem in my <service> or classes  or classpath,
but Axis isn't giving me a clue as to what the problem is.  

 

This is running ok in my Eclipse set-up, but it's set up somewhat differently there. 

 

I'm guessing that there is some subtle library version problem or classpath problem, and I've
been tinkering with both for many hours with no success yet. 

 

Any ideas on what might be causing this or how I can narrow down the problem?

 

I've tried to turn on DEBUG logging for axis, but no success with that yet either. Is there
a way to do that?

 

My setup is as follows:

 

Axis 1.2.1

Tomcat 5.5.17

Java 1.5.0_07

Linux Redhat 3.4.5-2, which if I remove my custom JAVA_HOME to JDK1.5 shows java version 1.4.2

 

>From the Yahoo search results, people seem to be finding their solution tinkering and
blind luck, so hopefully we're missing something simple about Axis deployment, yes?

 

Ben

 

 

 

This e-mail message may contain confidential and/or privileged information. If you are 

not an addressee or otherwise authorized to receive this message, you should not use, 

copy, disclose or take any action based on this e-mail or any information contained in the


message. If you have received this material in error, please advise the sender immediately


by reply e-mail and delete this message. 



Thank you.


Mime
View raw message