axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Brown" <matthew.br...@viecore.com>
Subject RE: Content is not allowed in prolog
Date Fri, 30 Jun 2006 14:16:26 GMT
Some followup information..
 
I've tested using .NET and their wsdl.exe tool to create a client to use the customer's web
service. The response still looks the same, but .NET has zero issues parsing. Could this just
be an XML parser issue? Can someone point me in the direction of how to change/configure the
parser, or find out if parsing a message such as the one below (with all those extra spaces)
is possible?
-----Original Message-----
From: Matthew Brown [mailto:matthew.brown@viecore.com]
Sent: Friday, June 30, 2006 9:23 AM
To: axis-user@ws.apache.org
Subject: RE: Content is not allowed in prolog


I happen to be having a similar error, although it isn't an endpoint issue.
 
The response we are getting back from the server looks like this:
 
??< ? x m l   v e r s i o n = " 1 . 0 "   e n c o d i n g = " u t f - 8 " ? > < s
o a p : E n v e l o p e   x m l n s : s o a p = " h t t p : / / s c h e m a s . x m l s o
a p . o r g / s o a p / e n v e l o p e / "   x m l n s : x s i = " h t t p : / / w w w .
w 3 . o r g / 2 0 0 1 / X M L S c h e m a - i n s t a n c e "   x m l n s : x s d = " h t
t p : / / w w w . w 3 . o r g / 2 0 0 1 / X M L S c h e m a " > < s o a p : H e a d
e r > < R e s p o n s e H e a d e r   x m l n s = " h t t p : / / b l a h . c o m /
C A S / " > < H e a d e r s > < / H e a d e r s > < / R e s p o n s e H
e a d e r > < / s o a p : H e a d e r > < s o a p : B o d y > < G e t A
c c o u n t I n f o r m a t i o n R e s p o n s e   x m l n s = " h t t p : / / b l a h .
c o m / C A S / " > < A c c o u n t I n f o r m a t i o n R e s p o n s e   x m l n
s : x s d = " h t t p : / / w w w . w 3 . o r g / 2 0 0 1 / X M L S c h e m a "   x m l n
s : x s i = " h t t p : / / w w w . w 3 . o r g / 2 0 0 1 / X M L S c h e m a - i n s t a
n c e "   x m l n s = " h t t p : / / b l a h . c o m / C A S / I V R . M e s s a g e D e
f i n i t i o n s . x s d " > 
 
     < N u m b e r O f M a t c h e s > 0 < / N u m b e r O f M a t c h e s > 
 
     < M o n t h l y E x t e n s i o n A m o u n t > 0 < / M o n t h l y E x t e
n s i o n A m o u n t > 
     
     ....
 

with garbage characters inserted between each legit XML character (and two before the prolog).
 
Is it possible to add a handler to modify the raw response XML before Axis passes it off to
the XML parser? Does anyone know? Is there some other simple setting I might be overlooking
that might be causing this?
 
Thanks in advance.
 

Mime
View raw message