axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Ethridge" <>
Subject RE: Problem deploying web service
Date Mon, 19 Jun 2006 21:56:02 GMT
It is my understanding that this is not a show-stopper error unless you
are using soap with attachments.  If you are using attachments, you need
to copy these jars from sun's website:


... place them in your axis/lib dir. Example:


I couldn't find this documented anywhere at Axis. I learned it from Kent
Tong's excellent book: "Developing Web Services with Apache Axis".

In your particular case my guess is it's a problem with your
AXISCLASSPATH, since you say you already have them in the lib dir. Get
another pair of experienced java eyes to look at your AXISCLASSPATH.  It
will probably be something hindsight, it usually is, but
when it happens, even experienced programmers struggle with it often
enough. There's just an awful lot of trees in the forest these days :-)


-----Original Message-----
From: Miller, Janet [] 
Sent: Monday, June 19, 2006 5:18 PM
Subject: Problem deploying web service

I'm trying to deploy a web service that I had deployed a few months ago.
My machine, however, got re-imaged, so I had to reinstall everything and
set up my paths, etc.  Now I can't get it to work.  When I tried to
deploy my WS, I got the following:

Jun 19, 2006 5:13:38 PM org.apache.axis.utils.JavaUtils
WARNING: Unable to find required classes (javax.activation.DataHandler
and javax
.mail.internet.MimeMultipart). Attachment support is disabled.
Processing file deploy.wsdd
<Admin>Done processing</Admin>

It doesn't have an error, so I can't tell if it was successful or not,
but it's not available on the axis page as a service.  I don't know why
it's unable to find javax.activation.DataHandler.  DataHandler exists in
activation.jar which is in my AXISCLASSPATH, in my Axis lib directory,
and also in C:\Program Files\Apache Software
Foundation\apache-tomcat-5.5.17\webapps\axis\WEB-INF\lib.  My axis is
happy, but I can't deploy a web service that I know worked before.

I know there's something simple that I'm doing wrong.  Can anyone help?


To unsubscribe, e-mail:
For additional commands, e-mail:

This e-mail message may contain confidential and/or privileged information. If you are 
not an addressee or otherwise authorized to receive this message, you should not use, 
copy, disclose or take any action based on this e-mail or any information contained in the

message. If you have received this material in error, please advise the sender immediately

by reply e-mail and delete this message. 

Thank you.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message